Bug 744189 - virtuoso not compatible with gawk-4.0
virtuoso not compatible with gawk-4.0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virtuoso-opensource (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker-kde
  Show dependency treegraph
 
Reported: 2011-10-07 07:54 EDT by Pierre-YvesChibon
Modified: 2011-10-13 00:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: virtuoso-opensource-6.1.3-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-13 00:31:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre-YvesChibon 2011-10-07 07:54:08 EDT
Description of problem:
I installed virtuoso and try to run conductor.

Version-Release number of selected component (if applicable):
$ rpm -q virtuoso-opensource-conductor.noarch
virtuoso-opensource-conductor-6.1.3-2.fc16.noarch


How reproducible:
always

Steps to Reproduce:
1. yum install virtuoso-opensource-conductor
2. sudo virtuoso-t +configfile /etc/virtuoso/virtuoso.ini +foreground
3. firefox http://localhost:8890/conductor/
  
Actual results:
two things:
$ sudo virtuoso-t +configfile /etc/virtuoso/virtuoso.ini +foreground

		Fri Oct 07 2011
13:52:19 { Loading plugin 1: Type `plain', file `wikiv' in `/usr/lib64/virtuoso/hosting'
13:52:19   FAILED  plugin 1: Unable to locate file }
13:52:19 { Loading plugin 2: Type `plain', file `mediawiki' in `/usr/lib64/virtuoso/hosting'
13:52:19   FAILED  plugin 2: Unable to locate file }
13:52:19 { Loading plugin 3: Type `plain', file `creolewiki' in `/usr/lib64/virtuoso/hosting'
13:52:19   FAILED  plugin 3: Unable to locate file }
13:52:19 OpenLink Virtuoso Universal Server
13:52:19 Version 06.01.3127-pthreads for Linux as of Sep 14 2011
13:52:19 uses parts of OpenSSL, PCRE, Html Tidy
13:52:19 Database version 3126
13:52:20 SQL Optimizer enabled (max 1000 layouts)
13:52:21 Compiler unit is timed at 0.001141 msec
13:52:22 Error compiling a server init statement : 37000: SQ074: Line 18: syntax error at '' -- create method
xmla_discover_keywords () returns any for xmla_discover
{
declare kwds, res any;
d...
13:52:22 Error compiling a server init statement : 37000: SQ074: Line 78: syntax error at '%' before 's' -- create method vc_render () for vspx_browse_button
{
if ( not self.vc_enabled)
return;

if (self....
13:52:22 Error compiling a server init statement : 37000: SQ074: Line 46: syntax error at '\' before ''\''' -- create method vc_render () for vspx_return_button
{
if ( not self.vc_enabled)
return;
if (self.b...
13:52:22 Error executing a server init statement : 22007: XM003: XML parser detected an error:
	ERROR  : 37000 XM029: XPath interpreter, line 0: Invalid character at %
 in . like ''%'' in attribute test of tag http://www.w3.org/1999/XSL/Transform:when in line 453 of file http://local.virt/vspx_expand
at line 453 column 38 of 'http://local.virt/vspx_expand'
      <xsl:when test=". like ''%''"><xsl:value-of select="." /></xsl:when>
------------------------------------^
 -- <?xml version='1.0'?>
<!--
 -  
 -  $Id: vspx_expa
13:52:22 Error executing a server init statement : 22007: XM003: XML parser detected an error:
	ERROR  : 37000 XM029: XPath interpreter, line 0: Invalid character at %
 in . like ''%'' in attribute test of tag http://www.w3.org/1999/XSL/Transform:when in line 4647 of file http://local.virt/vspx
at line 4647 column 34 of 'http://local.virt/vspx'
  <xsl:when test=". like ''%''"><xsl:value-of select="." /></xsl:when>
--------------------------------^
 -- <?xml version='1.0'?>
<!DOCTYPE xsl:stylesheet [
 
13:52:22 Roll forward started
13:52:22 Roll forward complete
13:52:28 Checkpoint started
13:52:28 Checkpoint finished, log reused
13:52:30 HTTP/WebDAV server online at 8890
13:52:30 Server online at 1111 (pid 13231)

which already shows some errors

Then when going to http://localhost:8890/conductor/
The log shows:
13:53:05 The function gethostbyname returned error 1 for host "local.virt".

This seem to be the error that blocks conductor.

Expected results:
The usual logs

Additional info:
Comment 1 Pierre-YvesChibon 2011-10-07 07:55:55 EDT
Additional info:

- On F14 (virtuoso-opensource-conductor-6.1.3-1.fc14.noarch) I have no problem
- I tried to rebuild virtuoso without the last patch (I wanted to test without the last change) but the problem persists.

100% reproducible, so I can help to debug this.
Comment 2 Rex Dieter 2011-10-11 14:19:12 EDT
OK, just tested 6.1.3-2.fc15.x86_64 and it seems to work ok too, though I do also get the same

13:52:19 { Loading plugin 1: Type `plain', file `wikiv' in
`/usr/lib64/virtuoso/hosting'
13:52:19   FAILED  plugin 1: Unable to locate file }
13:52:19 { Loading plugin 2: Type `plain', file `mediawiki' in
`/usr/lib64/virtuoso/hosting'
13:52:19   FAILED  plugin 2: Unable to locate file }
13:52:19 { Loading plugin 3: Type `plain', file `creolewiki' in
`/usr/lib64/virtuoso/hosting'
13:52:19   FAILED  plugin 3: Unable to locate file }

errors.


So, if you do indeed suspect some sort of name lookup error, what does these do on your box?  what's the output of:

hostname
host local.virt
Comment 3 Rex Dieter 2011-10-11 14:19:58 EDT
fwiw, after installing virtuoso-opensource-apps, the aforementioned errors about missing plugins goes away.
Comment 4 Pierre-YvesChibon 2011-10-11 14:31:38 EDT
The box was updated from F15 to F16, it was working on F15 (but maybe the previous release, I am not sure I had the last one.
Comment 5 Rex Dieter 2011-10-11 16:14:01 EDT
OK, I can indeed reproduce this on my f16 vm. 

After some scouring on the net, seems gawk-4.0 is the culprit.

http://www.google.com/search?q=virtuoso+gawk-4.0

http://sourceforge.net/tracker/index.php?func=detail&aid=3358418&group_id=161622&atid=820574

in particular, that includes a patch that I'll try out.
Comment 6 Fedora Update System 2011-10-11 20:52:51 EDT
virtuoso-opensource-6.1.3-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/virtuoso-opensource-6.1.3-3.fc16
Comment 7 Rex Dieter 2011-10-12 09:29:27 EDT
Marking F16Blocker-kde, virtuoso is pretty much completely broken and so is nepomuk by extension, making desktop search functionality hosed and will result in a multitude of crash reports.
Comment 8 Pierre-YvesChibon 2011-10-12 10:21:56 EDT
Works for me to.

I'll comment on the update once pushed to testing.
Comment 9 Kevin Kofler 2011-10-12 11:07:21 EDT
If you already tried the update from Koji, you can give positive karma right now, that way the package will go directly to stable.
Comment 10 Fedora Update System 2011-10-13 00:31:27 EDT
virtuoso-opensource-6.1.3-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.