Bug 74422 - redhat-config-soundcard doesn't initiliaze VIA8233 soundcard
redhat-config-soundcard doesn't initiliaze VIA8233 soundcard
Status: CLOSED DUPLICATE of bug 54905
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
athlon Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Garzik
David Lawrence
: FutureFeature
Depends On: 54905
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-23 20:20 EDT by Need Real Name
Modified: 2013-07-02 22:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-08 08:35:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-23 20:20:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
When running redhat-config-soundcard it properly identifies VT8233 AC97 Audio
controller. But when you hit "Play Test Sound" nothing happens. In  System Log
this is the entry from modprobe:
Sep 23 16:09:28 localhost insmod:
/lib/modules/2.4.18-11/kernel/drivers/sound/via82cxxx_audio.o: insmod
sound-slot-0 failed

Still no sound.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run redhat-config-soundcard
2.Program shows VT8233 AC97 Audio Controller.
3.Hit Play Test Sound

	

Actual Results:  Nothing Happens

Expected Results:  Expected to hear sound.

Additional info:

redhat-config-soundcard-1.0.0-2
AMD Athlon XP 2000+
MSI KT3 Ultra2 motherboard

Oh, and 1 more thing, there is no entry for redhat-config-soundcard-1.0.0-2 in
your bugzilla menu so I had to choose sndconfig to get this bug entered.
Comment 1 Bill Nottingham 2002-09-23 22:47:48 EDT
Sounds like a problem with the driver.
Comment 2 Need Real Name 2002-09-24 02:31:10 EDT
Sep 23 23:08:13 localhost insmod:
/lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o: init_module: No
such device
Sep 23 23:08:13 localhost insmod: Hint: insmod errors can be caused by incorrect
module parameters, including invalid IO or IRQ parameters.       You may find
more information in syslog or the output from dmesg
Sep 23 23:08:13 localhost insmod:
/lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o: insmod
sound-slot-0 failed
Sep 23 23:08:13 localhost modprobe: modprobe: Can't locate module sound-service-0-3

If this is a driver issue, who maintains the drivers that your software
supports? Where would one go to get updated drivers?
Comment 3 Paul Gear 2002-10-05 06:35:01 EDT
This sounds like a duplicate of 54905.  It still happens on 8.0 for VIA VT8233A
onboard sound.
Comment 4 Jeff Garzik 2002-10-08 10:54:13 EDT
via82cxxx_audio driver does not support VT8233 chipsets.


*** This bug has been marked as a duplicate of 54905 ***
Comment 5 Toralf 2002-10-25 15:44:05 EDT
http://www.viaarena.com/?PageID=60 has some valuable information on this.
Comment 6 Pawel Salek 2002-11-12 10:15:13 EST
Isn't this related to (#65837)?
If via82cxxx_audio does really not support this hardware, it means sndconfig has
got a problem (consider reassigning this report).

Note You need to log in before you can comment on or make changes to this bug.