Bug 74436 - Once touched by 1.0.7, keyring becomes unreadable elsewhere
Once touched by 1.0.7, keyring becomes unreadable elsewhere
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gnupg (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-24 06:56 EDT by Kevin Sonney
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-23 13:25:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Sonney 2002-09-24 06:56:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Once a keyring is modified by gnupg 1.0.7, versions of gpg included with earlier
distros can no longer read it. When attempting a --list-keys on a 1.0.7
maintained pubring with an older version of gnupg, packet errors are generated.
See below for more. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. modify an exisintg public keyring from psyche
2. attempt to list keys in that keyring on valhalla (7.3)
3. See the following error :
gpg: [don't know]: invalid packet (ctb=03)
gpg: read_keyblock: read error: invalid packet
gpg: enum_keyblocks(read) failed: invalid keyring


Actual Results:  This error happens on all available prior versions of GPG I
have to test - 1.0.6-0.6.x (from RHL 6.2) and 1.0.6-5 (from RHL 7.3). 

Expected Results:  I should see a list of keys, and I don't. 

Additional info:

Backporting 1.0.7 (from psyche) to 6.2 and 7.3 fixed the errors. in order to
compile on 6.x, LDAP had to be disabled in the .spec file.
Comment 1 Kevin Sonney 2002-09-24 10:12:44 EDT
addendum for completeness : also fails on AS 2.1 gnupg 1.0.6-3 (but that's not a
surprise)
Comment 2 Kevin Sonney 2003-01-23 13:25:24 EST
Closing, since this is a GPG "feature" and not something Red Hat can fix.

Note You need to log in before you can comment on or make changes to this bug.