Bug 74439 - rpmmodule fails to compile on solaris
rpmmodule fails to compile on solaris
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-24 09:07 EDT by Jeff Johnson
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-07 17:09:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Johnson 2002-09-24 09:07:03 EDT
The python module rpmmodule.so doesn't compile in Solaris.  I'm using
Sun's linker, which is where the problem comes from (binutils works fine,
so to speak).  The other shared libraries compile using Sun's LD, so I'm
thinking that the python Makefile needs something extra.

Here's my really cheesy patch.  This fixes the problem for me, hopefully
you can do something less frightening to help.  Note: 4.1 seems to have
the same problem.  If this problem has already been reported, I apologize.
Thanks a lot, as always!


--- rpm-4.0.4/python/Makefile.am.orig   Mon Sep 23 22:18:07 2002
+++ rpm-4.0.4/python/Makefile.am        Mon Sep 23 22:20:36 2002
@@ -11,7 +11,7 @@
        -I$(top_srcdir)/rpmio \
        -I$(top_srcdir)/beecrypt \
        -I$(top_srcdir)/popt \
-       -I/usr/include/python${PYVER} \
+       -I/usr/local/include/python${PYVER} \
        @INCPATH@

 EXTRA_DIST = hash.h upgrade.h
@@ -35,10 +35,10 @@
 librpmmodule_la_SOURCES = rpmmodule.c hash.c upgrade.c

 rpmmodule.so: $(librpmmodule_la_OBJECTS)
-       $(LINK) -o $@ $(librpmmodule_la_OBJECTS) $(rpmmodule_so_LDFLAGS)
+       /usr/ccs/bin/ld -G -h rpmmodule.so -o rpmmodule.so rpmmodule.o
hash.o upgrade.o ../lib/.libs/librpm.so ../rpmdb/.libs/librpmdb.so
../rpmio/.libs/librpmio.so -L/usr/local/lib -L/usr/ucblib -lrt -lpthread
../popt/.libs/libpopt.so -lnsl -lsocket -lz -lbz2  -R/usr/local/lib
-R/usr/ucblib

 poptmodule.so: $(poptmodule_so_OBJECTS)
-       $(LINK) -o $@ $(poptmodule_so_OBJECTS) $(poptmodule_so_LDFLAGS)
+       /usr/ccs/bin/ld -G -h poptmodule.so -o poptmodule.so poptmodule.o
../lib/.libs/librpm.so ../rpmdb/.libs/librpmdb.so
../rpmio/.libs/librpmio.so -L/usr/local/lib -L/usr/ucblib -lrt -lpthread
../popt/.libs/libpopt.so -lnsl -lsocket -lz -lbz2 -R/usr/local/lib
-R/usr/ucblib
Comment 1 Paul Nasrat 2005-06-07 17:09:30 EDT
Closing due to lack of activity.

If still an issue on rpm HEAD or rpm 4.4.x please reopen or discuss on rpm-devel
list

Check http://www.openpkg.org/ for Solaris rpm.

Note You need to log in before you can comment on or make changes to this bug.