Bug 744412 - Grub2 doesn't boot from GPT disk after EFI update on Asrock Z68 Pro3 board with AHCI enabled
Summary: Grub2 doesn't boot from GPT disk after EFI update on Asrock Z68 Pro3 board wi...
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 16
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2011-10-08 13:46 UTC by trivial+rhbugzilla
Modified: 2012-04-16 21:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2012-04-16 21:28:42 UTC
Type: ---

Attachments (Terms of Use)

Description trivial+rhbugzilla 2011-10-08 13:46:26 UTC
Description of problem:
Today I upgraded the firmware of my motherboard (Asrock Z68 Pro3) from version 1.10 to 1.60.
After that, grub2 won't load anymore from a disk with GUID partition table when AHCI is enabled in the efi setup. When the SATA controller is in the IDE compatibility mode, everything works fine. When grub2 is on a disk with a MBR, everything works fine as well (this is my workaround currently). Before the efi update, everything worked fine as well. There is no detailed changelog I could find, but the list of versions can be found here: http://www.asrock.com/mb/download.us.asp?Model=Z68%20Pro3&o=BIOS
I suspect the problem being the efi version 1.30, which lists "Modify for GPT mode." as Description...
When the problem occurs, I select to boot from the GPT disk, then at the top left of the screen is a blinking underscore for 1-2 seconds, and then, after that, the blinking underscore is like 2-3 cm below where it was previously and nothing happens anymore.

Version-Release number of selected component (if applicable):
latest grub2 from the repos, the system is installed with the F16-beta-dvd.

How reproducible:

Steps to Reproduce:
see above, tied tightly to my motherboard
Actual results:
system doesn't enter the bootloader menu

Expected results:
boot fine

Comment 1 Mads Kiilerich 2011-10-24 15:47:38 UTC
I guess this is a duplicate of bug 735733. Can you confirm that?

Comment 2 trivial+rhbugzilla 2011-10-26 17:24:09 UTC
I do not understand how i should proceed to confirm that. Can you give me some specific steps?

Comment 3 Mads Kiilerich 2011-10-26 17:38:45 UTC
You could try to read through bug 735733 and see if anything indicates that it is or isn't the same issue.

You could try to install with the nogpt option and verify that it really do make a difference.

You could also try to downgrade the bios and see when it broke and then ask the bios vendor for a bios that works.

Comment 4 Adam Williamson 2011-10-26 18:15:41 UTC
really this just sounds like the upstream BIOS vendor broke something in an update, to me. so we can call it a dupe of 735733 or closed upstream.

Comment 5 somsom01 2011-10-28 04:46:00 UTC
I experienced the same with Dell Inspiron N7110 (i7, 8GB RAM, 640GB HDD, NVidia 525 Optimus) BIOS A06.

So the issue is not limited to Asrock and Lenovo (bug 749325), but there must be quite many other manufacturers, including Dell.

"Install to Hard Disk" of FC16 TC3 Live CD using "Replace existing system(s)" partitioning option worked quite well for me, created all the partitions and created the FS fine. But GRUB2 was not installed, so on reboot I got "Operating System not found" error message.

Then I used nogpt option. The installer failed, as it was not able to find space on the disk. I had to use fdisk manually to remove GPT from partition table. Then installation went fine, the system boots from HDD.

I think entering a boot option and manually play with fdisk is not what people call seamless installation. It can be made automated, I think.

BTW, that GPT partition causing my issue was originally created by Win7. It seems that GRUB did not like that.

Comment 6 Mads Kiilerich 2011-10-28 10:05:05 UTC
(In reply to comment #5)
> But GRUB2 was not installed, so on reboot I got "Operating
> System not found" error message.

Just to clarify: do you know for sure that grub2 wasn't installed? In that case anaconda.log would be interesting. Or is it just your conclusion that when it doesn't work then grub2 wasn't installed correctly?

It also seems to me like your failure mode is a bit different than discussed here and on bug 749325. In their cases something (the boot loader) is hanging in slight different ways. In your case the bootloader isn't found at all.

Note also that this issue is using EFI boot(?) - it seems like you are using BIOS boot?

Comment 7 somsom01 2011-10-28 12:28:40 UTC
> do you know for sure that grub2 wasn't installed?

Sorry, my wording was really not correct, I am not sure what really happened. As we speak about my primary machine, I do not want to reproduce the issue to find what went wrong.

I actually tried "grub2-install /dev/sda" first and, as far as I remember, it printed some error logs. But maybe I just used it incorrectly.

> using BIOS boot?

I guess... I do not know, I just pressed shiny plastic button with rounded corners. :)

Comment 8 Mads Kiilerich 2011-10-28 13:14:29 UTC
(In reply to comment #7)

IMHO it look more and more like a completely different issue. Some specific information - such as the exact error messages and anaconda.log - could tell. I think it would be better to file a new issue for that.

Comment 9 Mads Kiilerich 2012-04-16 21:28:42 UTC
It is not clear what the real problem was here, and as pointed out in comment 4 it most of all looks like a bad firmware update.

Note You need to log in before you can comment on or make changes to this bug.