Bug 74443 - Libtiff depends broken
Libtiff depends broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: libtiff (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-24 10:36 EDT by Daniel Powell
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 15:19:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Powell 2002-09-24 10:36:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install libtiff
2. Try and install cups-libs
3. Cups libs requires libtiff.so.3
4. trying to determine which package provides i ran across a missing provides 
listing.

	

Actual Results:  cup-libs says it needs libtiff.so.3

[djpowell@Hydrometer djpowell]$ rpm -qf /usr/lib/libtiff.so.3
file /usr/lib/libtiff.so.3 is not owned by any package

[djpowell@Hydrometer djpowell]$ rpm -qf /usr/lib/libtiff.so.3.5
libtiff-3.5.7-6



Expected Results:  [djpowell@Hydrometer djpowell]$ rpm -
qf /usr/lib/libtiff.so.3.5
libtiff-3.5.7-6

libtiff.so.3 should resolve to the same package.

Additional info:

I dont know that this really affects the installation but i was trying to find 
what provided libtiff so i could install it on another system in order to get 
samba installed , samba requires libcups which requires libtiff. Libtiff was 
on another machine and i ran rpm -qf /usr/lib/libtiff.so.3 ... results as 
above. Should the provides list this file? even though libtiff.so.3 is a 
symlink.. it still seems as a normal file to the system and binareis linked 
against it.
Comment 1 Daniel Powell 2002-10-02 12:57:07 EDT
It may not be the depends per se, but rather that the RPM does not claim all 
the files.
Comment 2 Phil Knirsch 2002-10-04 11:05:04 EDT
I'll have to check the specfile and the depends stuff in there, maybe something
is wrong.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.