This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 744532 - udev lvm setup/link issues
udev lvm setup/link issues
Status: CLOSED DUPLICATE of bug 727925
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
15
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-09 05:24 EDT by udo
Modified: 2011-11-03 11:16 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-03 08:44:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log as requested (21.12 KB, text/plain)
2011-11-02 11:46 EDT, udo
no flags Details
log as requested (41.68 KB, text/plain)
2011-11-02 11:53 EDT, udo
no flags Details
log of activation (51.29 KB, text/plain)
2011-11-02 11:55 EDT, udo
no flags Details
kernel config (74.85 KB, text/plain)
2011-11-03 11:16 EDT, udo
no flags Details

  None (edit)
Description udo 2011-10-09 05:24:00 EDT
Description of problem:
dracut mentions that /dev/mapper nodes for lvm2 devices was not set up by udev; also dracut mentions that links under /dev were not created by udev

Version-Release number of selected component (if applicable):
udev-167-6.fc15.x86_64

How reproducible:
get kernel from kernel.org
compile kernel
install kernel
boot into kernel

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
see below

Expected results:
no such dracut complaints about udev

Additional info:
dracut: Scanning devices dm-0  for LVM volume groups 
dracut: Reading all physical volumes. This may take a while...
dracut: Found volume group "myvg" using metadata type lvm2
dracut: /dev/mapper/myvg-usrlv not set up by udev: Falling back to direct node creation.
dracut: /dev/mapper/myvg-varlv not set up by udev: Falling back to direct node creation.
dracut: /dev/mapper/myvg-homelv not set up by udev: Falling back to direct node creation.
dracut: /dev/mapper/myvg-datalv not set up by udev: Falling back to direct node creation.
dracut: /dev/mapper/myvg-srclv not set up by udev: Falling back to direct node creation.
dracut: /dev/mapper/myvg-optlv not set up by udev: Falling back to direct node creation.
dracut: /dev/mapper/myvg-wwwlv not set up by udev: Falling back to direct node creation.
dracut: /dev/mapper/myvg-newrootlv not set up by udev: Falling back to direct node creation.
dracut: /dev/mapper/myvg-rootlv not set up by udev: Falling back to direct node creation.
dracut: The link /dev/myvg/usrlv should had been created by udev but it was not found. Falling back to direct link creation.
dracut: The link /dev/myvg/varlv should had been created by udev but it was not found. Falling back to direct link creation.
dracut: The link /dev/myvg/homelv should had been created by udev but it was not found. Falling back to direct link creation.
dracut: The link /dev/myvg/datalv should had been created by udev but it was not found. Falling back to direct link creation.
dracut: The link /dev/myvg/srclv should had been created by udev but it was not found. Falling back to direct link creation.
dracut: The link /dev/myvg/optlv should had been created by udev but it was not found. Falling back to direct link creation.
dracut: The link /dev/myvg/wwwlv should had been created by udev but it was not found. Falling back to direct link creation.
dracut: The link /dev/myvg/newrootlv should had been created by udev but it was not found. Falling back to direct link creation.
dracut: The link /dev/myvg/rootlv should had been created by udev but it was not found. Falling back to direct link creation.
dracut: 9 logical volume(s) in volume group "myvg" now active

What is wrong? User error? kernel missing the fedora magic? 
Please let us know what info I can provide to help you fix or explain this issue.
Thanks.
Comment 1 Harald Hoyer 2011-10-10 04:48:36 EDT
Do you really want me to debug your kernel .config ? You probably have forgotten some udev cookie settings for lvm.
Comment 2 udo 2011-10-10 09:56:33 EDT
You mean there's now howto for such stuff?
When I google "udev cookie settings for lvm" I get stuff like http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Logical_Volume_Manager_Administration/udev_commands_interfaces.html which implies that I'd have to dig into udev scripting voodoo which I assume to be provided by Redhat/Fedora.
If just the kernel is custom, the initrd scripting is not. (!?)
Is some of the magic in this bug described at https://bugs.launchpad.net/ubuntu/+source/lvm2/+bug/802626 ?

There is no howto for such stuff?
Which kernel .config section is related to this udev/lvm issue so I can have look myself?
Comment 3 Fedora Admin XMLRPC Client 2011-10-20 12:09:13 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-10-20 12:11:27 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-10-20 12:13:19 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-10-20 12:17:46 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 udo 2011-10-21 08:42:02 EDT
For interested readers: https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=690308

(learned me a tad about what is going on)
Comment 8 Peter Rajnoha 2011-11-02 06:14:45 EDT
(In reply to comment #0)
> dracut: Found volume group "myvg" using metadata type lvm2
> dracut: /dev/mapper/myvg-usrlv not set up by udev: Falling back to direct node
> creation.
...
> What is wrong? User error? kernel missing the fedora magic? 
> Please let us know what info I can provide to help you fix or explain this
> issue.

Can you reproduce this if you deactivate/activate an LV later after the boot is complete? E.g. try to deactivate a volume that is not in use right after boot temporarily (I guess the "datalv" could be used for this test) and try to grab the debug output with -vvvv: "lvchange -an -vvvv myvg/datalv" and attach it here, please. Thanks.
Comment 9 udo 2011-11-02 11:46:17 EDT
Created attachment 531381 [details]
log as requested
Comment 10 udo 2011-11-02 11:49:25 EDT
Hmm, data was still in use, will retry.
Comment 11 udo 2011-11-02 11:53:02 EDT
Created attachment 531385 [details]
log as requested
Comment 12 udo 2011-11-02 11:55:10 EDT
Created attachment 531386 [details]
log of activation
Comment 13 Peter Rajnoha 2011-11-03 08:44:19 EDT
Well, looking at the logs, this is another instance of the problem that is already reported as bug #727925:

  #ioctl/libdm-iface.c:2017         Uevent not generated! Calling udev_complete internally to avoid process lock-up.

We found out one source of this problem, see also bug #727925 comment #4 and comment #11. Unfortunately, it seems we haven't found all possible sources of this problem based on the comment bug #727925 comment #12.

I'll close this bug as duplicate and add you on CC in the other bug report. Stay tuned...

*** This bug has been marked as a duplicate of bug 727925 ***
Comment 14 Peter Rajnoha 2011-11-03 08:56:09 EDT
(In reply to comment #0)
> How reproducible:
> get kernel from kernel.org
> compile kernel

Please, send the .config of the self-compiled kernel so we can compare it with the one in bug #727925 to see if there's something in common that might cause this bug to happen. Thanks.
Comment 15 udo 2011-11-03 11:16:45 EDT
Created attachment 531575 [details]
kernel config

Note You need to log in before you can comment on or make changes to this bug.