This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 74462 - dateconfig doesnt configure ntp correctly when using default ntp.conf
dateconfig doesnt configure ntp correctly when using default ntp.conf
Status: CLOSED DUPLICATE of bug 70557
Product: Red Hat Linux
Classification: Retired
Component: dateconfig (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-24 16:07 EDT by David Kaplan
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-22 15:39:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2002-09-24 16:07:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020710

Description of problem:
I am new to ntp and a bit confused, but it seems that dateconfig does not
properly configure ntp when used with the default ntp.conf that comes with the
redhat rpm.  This default conf file has at the top:

# Prohibit general access to this service.
restrict default ignore

This prohibits all access to ntp unless there is a restrict line of the form 

restrict mytrustedtimeserverip mask 255.255.255.255 nomodify notrap noquery

for every server (if I understand correctly).  As dateconfig doesnt add such a
line when you select the server, it does not configure ntp to work properly. 
This means that you have to change the conf file by hand (and learn a lot about
ntp), which defeats the purpose of a GUI.  

Perhaps I dont understand something, but it took me a long time to set up
something which should be really simple.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run dateconfig
2.select use ntp
3.select a server and apply
	

Actual Results:  Time doesnt get synced up and ntpq -p shows no activity.

Expected Results:  ntp does it's thing.

Additional info:
Comment 1 Brent Fox 2002-10-22 15:39:34 EDT
Can you try redhat-config-date-1.5.3-1 from Rawhide?  Things work fine for me
with this version, although the 'restrict mytrustedtimeserverip mask
255.255.255.255 nomodify notrap noquery' does not seem to be necessary for NTP
to work.
Comment 2 Brent Fox 2002-10-25 14:25:15 EDT

*** This bug has been marked as a duplicate of 70557 ***

Note You need to log in before you can comment on or make changes to this bug.