Bug 744624 - python3 fails to build on ARM
python3 fails to build on ARM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python3 (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Malcolm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-09 15:27 EDT by Daniel Drake
Modified: 2011-10-10 16:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-10 14:17:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
new build for ARM test exclusion (4.94 KB, patch)
2011-10-09 15:27 EDT, Daniel Drake
no flags Details | Diff

  None (edit)
Description Daniel Drake 2011-10-09 15:27:20 EDT
Created attachment 527114 [details]
new build for ARM test exclusion

The python3 package in F15 fails to build in ARM, due to test failures in test_pty, test_openpty, and test_float. The issues with these tests are well documented on this bugzilla, already worked around in F14+ python2 and F16+ python3 (thanks!).

However, the F15 failure is blocking our F15-on-ARM efforts.

To complete the puzzle, is it OK for me to commit the attached spec file change, and do a new F15 build in koji? (without pushing to updates - no need). 

The patch is made up from two earlier commits to the f16 branch. I see that the most recent versions now handle test exclusions more elegantly, but in the interests of the F15 stable branch I'm thinking that the old approach (taken in my patch) is less risky/less intrusive.
Comment 1 Dave Malcolm 2011-10-10 11:39:55 EDT
Looks reasonable; go for it (just in F15, though, as you said).

BTW, does the F17's python and python3 build OK on ARM?  (i.e. did I break anything when I rewrote the test exclusions to be more fine-grained?)
Comment 2 Daniel Drake 2011-10-10 14:17:01 EDT
Thanks for the quick review, pushed and built. I'll get back to you about the F17 version - its building now. We aren't building F16/F17 yet but I figure I can test what you're looking for by building that version on top of F15. I'll let you know.
Comment 3 Daniel Drake 2011-10-10 16:27:12 EDT
The F17 build works. Thanks for thinking of the ARMs!
Comment 4 Dave Malcolm 2011-10-10 16:41:37 EDT
(In reply to comment #3)
> The F17 build works. Thanks for thinking of the ARMs!

Excellent!  Thanks for checking it.

Note You need to log in before you can comment on or make changes to this bug.