Bug 744641 - system-setup-keyboard ignored KEYTABLE
system-setup-keyboard ignored KEYTABLE
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-setup-keyboard (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-09 19:30 EDT by Peter Hutterer
Modified: 2011-11-28 19:21 EST (History)
4 users (show)

See Also:
Fixed In Version: system-setup-keyboard-0.8.8-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-20 00:00:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hutterer 2011-10-09 19:30:46 EDT
Description of problem:
If /etc/sysconfig/keyboard only has KEYTABLE but none of the xkb options set, s-s-k does not use the keytable to select XKB options but instead just dumps an essentially empty 00-system-config-keyboard.conf

Additional info:
Accidentally removed in: 
http://git.fedorahosted.org/git/?p=system-setup-keyboard.git;a=commitdiff;h=8533d18435aa48fba4e18fc087e29c7e49c44f9b
Comment 1 Peter Hutterer 2011-10-09 19:47:39 EDT
Marking as F16 blocker, this really shouldn't happen.
Comment 2 Fedora Update System 2011-10-09 19:48:31 EDT
system-setup-keyboard-0.8.8-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/system-setup-keyboard-0.8.8-1.fc16
Comment 3 Fedora Update System 2011-10-09 19:59:01 EDT
system-setup-keyboard-0.8.8-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/system-setup-keyboard-0.8.8-1.fc15
Comment 4 Håkan Hjort 2011-10-10 08:18:20 EDT
I was not able to get it to update the file automatically (or at start up).  My knowledge about systemd isn't great enough for me to be able to tell if it even tried to launch it.
Manually running it, it does place the correct output into /etc/X11/xorg.conf.d/00-system-setup-keyboard.conf
Comment 5 Fedora Update System 2011-10-10 22:59:22 EDT
Package system-setup-keyboard-0.8.8-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-setup-keyboard-0.8.8-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14119
then log in and leave karma (feedback).
Comment 6 Adam Williamson 2011-10-14 14:20:47 EDT
Discussed at 2011-10-14 blocker review meeting. To assess blocker status of this bug we'd need to know the practical impact it has. Could this somehow be the cause of https://bugzilla.redhat.com/show_bug.cgi?id=743281 ?
Comment 7 Peter Hutterer 2011-10-17 21:18:09 EDT
(In reply to comment #6)
> Discussed at 2011-10-14 blocker review meeting. To assess blocker status of
> this bug we'd need to know the practical impact it has. Could this somehow be
> the cause of https://bugzilla.redhat.com/show_bug.cgi?id=743281 ?

practical impact: if a /etc/sysconfig/keyboard with only the KEYTABLE option is present the user will see "us" as the keyboard layout once X is started. The users can override this through selecting a keyboard in gdm.

I don't think it's related to Bug 743281. All s-s-k does is write out an xorg.conf.d snippet and X isn't started until well after the password prompt.
Comment 8 Fedora Update System 2011-10-20 00:00:57 EDT
system-setup-keyboard-0.8.8-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2011-11-28 19:21:05 EST
system-setup-keyboard-0.8.8-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.