Bug 744671 - Option to enable 'Enter' to save and move to the next string and use Shift+Enter to add a new line
Option to enable 'Enter' to save and move to the next string and use Shift+En...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.4.2
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks: 740191 Zanata-1.4.2
  Show dependency treegraph
 
Reported: 2011-10-10 01:55 EDT by James Ni
Modified: 2013-03-03 21:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-28 03:02:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Ni 2011-10-10 01:55:10 EDT
As a translator I want a to set an Option to enable 'Enter' to save and move to the next string and use Shift+Enter to add a new line, so that I can quickly edit and navigate while working on on the editor

-add options menu to enable 'Enter' to save and move to the next string
-dynamically change tooltips for Save as Approved button
Comment 2 Ding-Yi Chen 2011-10-11 22:11:45 EDT
James, this bug is re-assigned to you because:

1. Ctrl-Enter should still be working as "Saved as Approved" when "Enable 'Enter' Key to save" is off.

2. Shift-Enter should be able to insert the newline, no matter "Enable 'Enter' Key to save" is on or off.
Comment 3 James Ni 2011-10-12 02:01:51 EDT
(In reply to comment #2)
> James, this bug is re-assigned to you because:
> 
> 1. Ctrl-Enter should still be working as "Saved as Approved" when "Enable
> 'Enter' Key to save" is off.
> 
> 2. Shift-Enter should be able to insert the newline, no matter "Enable 'Enter'
> Key to save" is on or off.

OK, I will reinstate the Ctrl-Enter, and make 'Shift-Enter' be able to insert the newline, when "Enable 'Enter' Key to save" is on
Comment 4 James Ni 2011-10-12 04:04:42 EDT
Hi Ding,

I have modified the code to reinstate Ctrl-Enter to be working as "Saved as Approved" when "Enable 'Enter' Key to save" is off.

I also found that Shift-Enter should be able to insert the newline when "Enable 'Enter' Key to save" is off. And we don't need any further key event handler for Shift-Enter when "Enable 'Enter' Key to save" is off.
Comment 5 Sean Flanigan 2011-10-14 02:28:32 EDT
Dean, are you happy with this now?
Comment 6 Ding-Yi Chen 2011-10-16 20:58:38 EDT
VERIFIED with Zanata version 1.4.2-SNAPSHOT (20111014-1658).

Note You need to log in before you can comment on or make changes to this bug.