Bug 744712 - Abrt can't extract libreoffice debuginfo package
Abrt can't extract libreoffice debuginfo package
Status: CLOSED DUPLICATE of bug 790396
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Denys Vlasenko
Fedora Extras Quality Assurance
:
: 781734 (view as bug list)
Depends On:
Blocks: ABRTF18
  Show dependency treegraph
 
Reported: 2011-10-10 05:23 EDT by Pavel Alexeev
Modified: 2012-09-18 07:26 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 07:26:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2011-10-10 05:23:24 EDT
Description of problem:
I choose local process of crash dump. Debuginfo package downloaded, but can't be extracted without say any reason. Part of log:

--- Running analyze_LocalGDB ---
Analyzing coredump 'coredump'
Coredump references 235 debuginfo files, 115 of them are not installed
Setting up yum repositories
Looking for needed packages in repositories
Can't find packages for 3 debuginfo files
Packages to download: 3
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:   3%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:   5%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:   7%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:   9%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  11%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  13%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  15%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  17%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  19%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  21%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  23%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  25%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  27%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  29%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  31%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  33%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  35%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  37%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  39%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  41%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  43%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  45%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  47%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  49%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  51%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  53%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  55%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  57%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  59%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  61%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  63%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  65%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  67%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  69%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  71%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  73%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  75%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  77%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  79%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  81%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  83%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  84%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  86%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  88%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  90%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  92%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  94%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  96%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm:  98%
Downloading (1 of 3) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm: 100%
Extracting cpio from /tmp/abrt-tmp-debuginfo-2011-10-10-12:46:36.22668/libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm
Can't extract package '/tmp/abrt-tmp-debuginfo-2011-10-10-12:46:36.22668/libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm'
Unpacking failed, aborting download...


Please say how I can't provide additional info.

Version-Release number of selected component (if applicable):
$ rpm -qa 'abrt*'
abrt-libs-2.0.4.981-3.fc16.x86_64
abrt-addon-kerneloops-2.0.4.981-3.fc16.x86_64
abrt-addon-python-2.0.4.981-3.fc16.x86_64
abrt-2.0.4.981-3.fc16.x86_64
abrt-retrace-client-2.0.4.981-3.fc16.x86_64
abrt-addon-vmcore-2.0.4.981-3.fc16.x86_64
abrt-desktop-2.0.4.981-3.fc16.x86_64
abrt-addon-ccpp-2.0.4.981-3.fc16.x86_64
abrt-gui-2.0.4.981-3.fc16.x86_64

How reproducible:
Always.
Comment 1 Nikola Pajkovsky 2011-10-10 05:36:26 EDT
go into <dump-dir> -- I assume you have it in your ~/.abrt/spoo/ccpp-*

log as root and run

$ abrt-action-install-debuginfo -vvv
Comment 2 Pavel Alexeev 2011-10-16 18:16:05 EDT
It still the same:
$ cd /home/pasha/.abrt/spool/ccpp-2011-10-09-13:20:03-27671
LANG=C abrt-action-install-debuginfo -vvv
[skip]
percentage is the same, not updating progress
percentage is the same, not updating progress
percentage is the same, not updating progress
percentage is the same, not updating progress4.3.2-11.fc16.x86_64.rpm:  99%
percentage is the same, not updating progress
percentage is the same, not updating progress
percentage is the same, not updating progress
percentage is the same, not updating progress
percentage is the same, not updating progress
percentage is the same, not updating progress
percentage is the same, not updating progress
percentage is the same, not updating progress
Downloading (1 of 1) libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm: 100%
Extracting /tmp/abrt-tmp-debuginfo-2011-10-17-01:42:44.6434/libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm to /var/cache/abrt-di
['/usr/lib/debug/.build-id/44/48a6d7b3b364860a86559c1b3728f3279bf2fe.debug', '/usr/lib/debug/.build-id/fc/32ad002deebac7a24a1635381e1f7e27141bf4.debug', '/usr/lib/debug/.build-id/28/b80003d0af9ae51a57d29d7ac777e1a0737644.debug', '/usr/lib/debug/.build-id/3f/33d3dd4cf7a6cfc2964e59b0a25df32f82a416.debug', '/usr/lib/debug/.build-id/ba/0d2215363172539035fed23045155d62f8016b.debug', '/usr/lib/debug/.build-id/94/77317fa8498f1946f8fab708a056968f1b4328.debug',
[skip]
 '/usr/lib/debug/.build-id/e3/64a0e52fc7c3a41e4caa387cd27889f8edbacd.debug', '/usr/lib/debug/.build-id/81/eb2e9f77c29d5429214f186610b5f1a65b356a.debug', '/usr/lib/debug/.build-id/bf/39399fb3522729b19a2e894bb05cb0e4df37f5.debug', '/usr/lib/debug/.build-id/c6/f377e700bbc426a13730d655b13a9f0c5043c9.debug', '/usr/lib/debug/.build-id/67/53b40223d1ac0f8a76740b540291c21b44fafd.debug', '/usr/lib/debug/.build-id/aa/ede7303de154cfc3e77f5f5743ebb77bc30fb8.debug']
Extracting cpio from /tmp/abrt-tmp-debuginfo-2011-10-17-01:42:44.6434/libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm
Can't extract package '/tmp/abrt-tmp-debuginfo-2011-10-17-01:42:44.6434/libreoffice-debuginfo-3.4.3.2-11.fc16.x86_64.rpm'
Unpacking failed, aborting download...
Comment 3 Jiri Moskovcak 2012-08-10 06:13:57 EDT
Do you still experience this bug?
Comment 4 Pavel Alexeev 2012-08-15 15:51:43 EDT
I think no. New abrt totally do not provide choose to local handle crash...
Comment 5 Jiri Moskovcak 2012-09-18 06:54:34 EDT
*** Bug 781734 has been marked as a duplicate of this bug. ***
Comment 6 Karel Klíč 2012-09-18 07:26:00 EDT
This is bug #790396.

*** This bug has been marked as a duplicate of bug 790396 ***

Note You need to log in before you can comment on or make changes to this bug.