Bug 74475 - rpm database corrupt
rpm database corrupt
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-24 19:15 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 11:44:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-24 19:15:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
Can not use any program reliant on reading rpm database.  I get segmentation
faults mostly.  Have tried the basic steps found to rebuild the database as
found in the bugzilla archive, but still get a segfault when querying.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.launch any rpm manager
2.Wait for crash
3.
	

Actual Results:  Segmentation fault, or Crash window from both Gnome and KDE

Expected Results:  rpm install working and rpm database ok

Additional info:

 db_dump Packages-ORIG | db_load Packages 
[root@bblut rpm]# rpm -qa
......
gimp-perl-1.2.3-4.ximian.4
gnapster-1.4.2-1.ximian.4
kernel-2.4.18-10
Segmentation fault

 db_verify Packages
db_verify: Program version 3.3.11 doesn't match environment version 4.0.14
Comment 1 Jeff Johnson 2002-09-25 09:25:20 EDT
Doing
	rm -f /var/lib/rpm/__db*
should permit db_verify to function.

Otherwise, get the db-4.0.14 db_verify
by installing the db4-utils-4.0.14
package, using rpm2cpio manually if necessary.
Comment 2 Need Real Name 2002-09-25 11:11:54 EDT
Where can I find this new package?  I was unable to find it at rpmfind.net. 
Please let me know.

Thanks
Comment 3 Jeff Johnson 2002-09-25 11:14:52 EDT
Did
	rm -f /var/lib/rpm/__db*
permit you to run db_verify?
Comment 4 Need Real Name 2002-09-25 11:18:46 EDT
Oh, sorry about that.  Yes, it did verify packages without the __db.  What now?
Comment 5 Jeff Johnson 2002-09-25 11:22:32 EDT
FWIW, db4-4.0.14 should be at rpmfind.net,
but you might have to rebuild from a src.rpm
for 7.3.

OK, if Packages verifies, the next
step is
	rpm --rebuilddb
If the rebuild succeeds, test with "rpm -qa".
Comment 6 Need Real Name 2002-09-25 11:28:48 EDT
This is exactly as before, I guess I didn't copy enough lines off of my
terminal.  I did this again just in case, but still get a segfault on the rpm -qa.
Comment 7 Jeff Johnson 2002-09-25 11:32:51 EDT
OK, that's what I needed to know.

Can you give me a pointer (i.e. URL,
bugzilla attachments won't work) to a
tarball of your database
	cd /var/lib
	tar czvf /tmp/rpmdb-74475.tar.gz rpm
please?
Comment 8 Need Real Name 2002-09-25 11:44:25 EDT
ok, here is where you can find it.

www.aperio.com/software/beta/rpmdb-74475.tar.gz
Comment 9 Jeff Johnson 2002-10-08 09:09:18 EDT
I think I fixed this problem, but I fergit.
Feel free to reopen if it's still an issue.

Note You need to log in before you can comment on or make changes to this bug.