Bug 74476 - inspiron 8100 failes to suspend/resume with 2.4.18-11
inspiron 8100 failes to suspend/resume with 2.4.18-11
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-24 19:16 EDT by Red Hat Bugzilla
Modified: 2008-03-13 15:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 21:44:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vv output (8.90 KB, text/plain)
2002-09-24 19:17 EDT, Red Hat Bugzilla
no flags Details
relevant /var/log/messages and lsmod output (39.26 KB, text/plain)
2002-09-24 19:18 EDT, Red Hat Bugzilla
no flags Details

  None (edit)
Description Red Hat Bugzilla 2002-09-24 19:16:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
Dell Inspiron 8100 fails to resume after a suspend with kernel 2.4.18-11.  The
machine physically unsuspends, but the system does not repond.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Suspend
2. Resume

	

Actual Results:  If in a text console, console text comes back, but machine does
not respond.  If in X, screen remains blank.

Expected Results:  Correct unsuspend.

Additional info:

Machine is able to resume correctly with 2.4.18-0.21 (except for the occasional
screwed X unsuspend).  Problems began with (null) upgrade from 7.2 (said upgrade
having "helpfully" removed older kernel packages).

Will attach lsmod, lspci -vv, and relevant /var/log/messages output.
Comment 1 Red Hat Bugzilla 2002-09-24 19:17:13 EDT
Created attachment 77144 [details]
lspci -vv output
Comment 2 Red Hat Bugzilla 2002-09-24 19:18:25 EDT
Created attachment 77145 [details]
relevant /var/log/messages and lsmod output
Comment 3 Red Hat Bugzilla 2002-09-24 19:28:19 EDT
Also tried with both bios version A10 and A13 (sorry for the bugzilla spam :)
Comment 4 Red Hat Bugzilla 2002-09-26 07:20:24 EDT
I also have an inspiron 8100, I believe with the same options (ie, Radeon M7),
and experienced the same problem. 

The symtom for me was that whenever waking up from a suspend state, the hard
disk would wirr away, but I would only have a blank screen. The only way to get
out of this was to hard-reboot.
Comment 5 Red Hat Bugzilla 2002-09-26 07:24:07 EDT
I think I found the cause for this.
To verify the hypothesis, please try the i586 kernel and see if that one works.
If it does, I know how to fix it.
Comment 6 Red Hat Bugzilla 2002-09-26 20:02:32 EDT
Just tested with 2.4.18-11-i586, and am able to suspend and resume correctly. 
So I'm guessing you know how to fix it :)
Comment 7 Red Hat Bugzilla 2002-10-19 06:13:30 EDT
ping... any progress on this?  Stock 2.4.19 suspend/resume works fine, but
eepro100 doesn't get reinitialized correctly at boot (I'm assuming the
dell/eepro100 patch hasn't made it to the upstream yet).
Comment 8 Red Hat Bugzilla 2002-10-19 06:59:21 EDT
the released erratum from a few days ago is supposed to fix this..
Comment 9 Red Hat Bugzilla 2002-10-19 18:35:51 EDT
Ah ok; didn't see tihs bug in the fixed-bugs list.  Downloaded it last night,
didn't install it yet.

Note You need to log in before you can comment on or make changes to this bug.