Bug 744770 - MessageBar after creating a group contains html
MessageBar after creating a group contains html
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
: 746379 (view as bug list)
Depends On:
Blocks: jon30-sprint8
  Show dependency treegraph
 
Reported: 2011-10-10 08:19 EDT by Heiko W. Rupp
Modified: 2012-02-07 14:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:21:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the green bar with html (6.38 KB, image/png)
2011-10-10 08:19 EDT, Heiko W. Rupp
no flags Details

  None (edit)
Description Heiko W. Rupp 2011-10-10 08:19:16 EDT
Created attachment 527230 [details]
Screenshot of the green bar with html

Create a new compat group, watch the green bar at the top containing html

This is a result of https://bugzilla.redhat.com/show_bug.cgi?id=742614 , where HTML is filtered out.

We have two options
- change this message (the new group shows up in the list below anyway)
- change the way Messages are filtered to contain some special "is safe" flag
Comment 1 Charles Crouch 2011-10-12 10:27:07 EDT
My two cents. Option 1), change the message. Safe and easy
Comment 2 Heiko W. Rupp 2011-10-15 04:15:06 EDT
*** Bug 746379 has been marked as a duplicate of this bug. ***
Comment 3 Heiko W. Rupp 2011-10-15 05:10:25 EDT
f867ef2 in master
Comment 4 Sunil Kondkar 2011-10-18 06:08:24 EDT
Verified on build#552 (Version: 4.1.0-SNAPSHOT Build Number: 291cdab)

Created a compatible group and verified that the messagebar does not contain html. It displays the message "You have created a new resource group."
Comment 5 Mike Foley 2012-02-07 14:21:27 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.