Bug 74482 - Mailman logrotate problem hard to fix
Mailman logrotate problem hard to fix
Status: CLOSED DUPLICATE of bug 74483
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-25 02:01 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-25 02:01:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
This refers to known bug in logrotate/mailman pertaining to incorrect
configuration that creates an infinite number of empty files in /var/log/mailman

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Disable mailman, but keep in on the system
2. run logrotate
3. watch files in /var/log/mailman
4. try to remove these files (rm -rf /var/log/mailman works best)
5. remove mailman from system (rpm -e mailman)
6. try to run logrotate again: it takes forever!

Actual Results:  A very large number of files were created in /var/log/mailman
(300,000+ in my case), named thus:

error.1
error.1.1
error.1.1.1
etc

*BUT ALSO* a very large (17MB+) status file was created as

/var/lib/logrotate.status



Expected Results:  Logrotate takes too much time to complete (hours!)


Additional info:

To fix logrotate, one must also:

1- delete /var/lib/logrotate.status

2- run /usr/sbin/logrotate -v -f  /etc/logrotate.conf
Comment 1 John Dennis 2003-04-24 15:45:03 EDT

*** This bug has been marked as a duplicate of 74483 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:49:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.