Bug 744841 - Locale::Language is missing from the perl core package
Locale::Language is missing from the perl core package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bugzilla (Show other bugs)
16
All All
unspecified Severity medium
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
http://perldoc.perl.org/Locale/Langua...
:
: 754625 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-10 12:01 EDT by Frédéric Buclin
Modified: 2012-01-18 20:30 EST (History)
12 users (show)

See Also:
Fixed In Version: bugzilla-3.6.7-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-18 20:29:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frédéric Buclin 2011-10-10 12:01:35 EDT
Per http://perldoc.perl.org/Locale/Language.html, Locale::Language is part of the core distribution of Perl, but this module is missing from perl-5.14.1-188.fc16.i686. This prevents e.g. checksetup.pl in Bugzilla from running correctly.
Comment 1 Marcela Mašláňová 2011-10-10 12:36:16 EDT
Now is Locale::Language part of sub-package perl-Locale-Codes. Your problem will be fixed by installation of this sub-package. 

I'll reassign this bug to bugzilla, which should require it.
Comment 2 Frédéric Buclin 2011-10-10 12:58:39 EDT
So you make the assumption that all installations with Perl applications depending on this core module will have perl-Locale-Codes installed. This is a pretty bad guess. The goal of having core modules is to have them installed and available by default. Why has this module been extracted from the core package, to start with?
Comment 3 Marcela Mašláňová 2011-10-10 13:36:54 EDT
If you are using perl core modules, you should install perl-core:
A metapackage which requires all of the perl bits and modules in the upstream
tarball from perl.org.

If it was up to me everyone have to use perl and all core modules. But not everyone is interested. For example in buildroot is needed only perl, not all core packages. Another reason why we split perl into sub-packages is, updates of core modules. We already have this discussion even with upstream. We can't make everyone happy with Perl packaging.
Comment 4 Frédéric Buclin 2011-10-10 14:18:53 EDT
I see, thanks for the explanation. In that case, Bugzilla should depend on perl-core, to make sure we don't fail every time a core module is put outside the perl package.
Comment 5 Petr Pisar 2011-10-10 15:41:31 EDT
The recommended way is to depend on `perl(Locale::Language)'. Each perl code exporting a Perl module `Foo' provides `perl(Foo)' in Fedora. This allows to track dependencies even if Perl modules moves between RPM packages. Actually you should get these dependencies into RPM metadata automatically by rpmbuild.
Comment 6 Emmanuel Seyman 2011-10-11 07:36:02 EDT
(In reply to comment #2)
>
> The goal of having core modules is to have them installed and available by
> default.

FWIW, most distributions do not install the full core suite when you install the package containing /usr/bin/perl. 


(In reply to comment #5)
>
> Actually you should get these dependencies into RPM metadata automatically by
> rpmbuild.

Doing a mock rebuild, I realized that rpm's auto-requires mechanism doesn't add perl(Locale::Language) to the package's requires so I'm guessing that rpm doesn't add modules that are require-ed as opposed to use-d.

I'll commit a fix.
Comment 7 Emmanuel Seyman 2011-11-22 03:59:17 EST
*** Bug 754625 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2012-01-08 10:52:26 EST
bugzilla-3.6.7-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bugzilla-3.6.7-1.fc15
Comment 9 Fedora Update System 2012-01-08 10:52:42 EST
bugzilla-4.0.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/bugzilla-4.0.3-1.fc16
Comment 10 Fedora Update System 2012-01-11 01:04:21 EST
Package bugzilla-4.0.3-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bugzilla-4.0.3-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0301/bugzilla-4.0.3-1.fc16
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-01-18 20:29:59 EST
bugzilla-4.0.3-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-01-18 20:30:24 EST
bugzilla-3.6.7-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.