Bug 74493 - SquirrelMail URL is not obvious
SquirrelMail URL is not obvious
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: squirrelmail (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-25 06:33 EDT by -M
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-08 06:06:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description -M 2002-09-25 06:33:03 EDT
Description of Problem:
Since there is no man page and there is no info page and there is no /mail or
/squirrelmail folder in /var/www/html/ Where is squirrelmail and how do we get
to it?
Comment 1 Gary Benson 2002-09-25 06:46:04 EDT
Try http://localhost/webmail/
Comment 2 -M 2002-09-25 22:27:19 EDT
Yep that's it but I can not get past the login now with either root or a user. 
root I would expect the user account I have no clue as to why it will not 
work. I took the cookies and the page changed and told me I had to be logged 
in to access that page.
Comment 3 -M 2002-09-26 00:32:54 EDT
So finally I find that there is a squirrelmail.cfg in file:/etc/httpd/conf.d  
which I would could have been put in httpd.conf to help avoid the confusion.  
  
Also I noticed that is says this:  
  
SquirrelMail does not yet work with register_globals off (#68669)  
  
But the website http://www.squirrelmail.org/changelog.php says this:  
  
ANNOUNCE: SquirrelMail 1.2.8 Released  
 Sep 14, 2002 by Jason Munro  
  
  SquirrelMail 1.2.8 has been released. The big news is that SquirrelMail will  
now work with the PHP register_globals setting to off. Like all stable  
releases this one contains no new features, only bug fixes.  
  
So are we running an older version?  
  
Might I suggest we check on the ideal of haveing the administrator plugin 
included? Just an ideal. 
 
Any way so I found the soulution as to why I could not login: 
 
"You don't have an IMAP server configured. Squirrelmail reports the same error 
if an IMAP connection is refused by the server. Check /etc/xinet.d/imap to 
enable the server." 
 
Well is was not running which may have been my fault i don't remeber if i 
turned it off or if it was not enabled by default. 
 
We could seriously use some documentation on the whole program since someone 
chose to install it in a more confusing way than normal. 
 
Thanks 
  
 
 
 
 
Comment 4 Gary Benson 2002-09-26 05:25:48 EDT
1. All files matching /etc/httpd/conf.d/*.conf are loaded by httpd on startup.
   The directory exists so that rpms can drop configuration files into it.

2. The version of SquirrelMail in (null) is 1.2.7.

3. The administrator plugin is included.

4. "someone chose to install it in a more confusing way than normal."
   It installs in exactly the same way as the upstream rpm ;)
Comment 5 -M 2002-09-26 08:38:53 EDT
Sorry but without any docs I had to go to there site and could only find
instructions for gunziped tar which seemed more simple to me since it installed
to /var/www/html which ofcourse is what made things confusing. Anyway I updated
mine to 1.2.8 it was easy enough. If only I could get this rpm creation thing
down *sigh*

Thanks for the replies.
Comment 6 -M 2002-10-01 03:43:28 EDT
Moving on to 8.0 release.
Comment 7 Gary Benson 2004-01-08 06:06:31 EST
/webmail/ is now the upstream default, so it should prove easier to
find now.

Note You need to log in before you can comment on or make changes to this bug.