Bug 744980 - PackageKit EL6 issue - gpk-update-viewer (Software Update) goes blank
Summary: PackageKit EL6 issue - gpk-update-viewer (Software Update) goes blank
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-packagekit
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 782183 840699
TreeView+ depends on / blocked
 
Reported: 2011-10-11 05:01 UTC by Rodrigo Trujillo
Modified: 2018-11-30 22:55 UTC (History)
5 users (show)

Fixed In Version: gnome-packagekit-2.28.3-7.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 07:47:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshots of the blank window. (60.15 KB, application/zip)
2011-10-17 04:41 UTC, Rodrigo Trujillo
no flags Details
gpk-update-viewer -v (133.03 KB, application/x-gzip)
2012-02-16 15:33 UTC, Grant Williamson
no flags Details
pkmon of upgrade process (29.77 KB, application/x-bzip)
2012-02-16 15:34 UTC, Grant Williamson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0280 normal SHIPPED_LIVE gnome-packagekit bug fix update 2013-02-20 20:37:02 UTC

Description Rodrigo Trujillo 2011-10-11 05:01:30 UTC
Description of problem:
During our upgrades from EL6.0 to EL 6.1 and 6.1 to 6.2, gpk-update-viewer goes blank. According to out tests, gpk-update-viewer goes blank when packagekitd emits a "repo-list-changed".
This seems to be triggered when specific packages are updated.

We ran 3 tests with packagekitd and gpk-update-viewer in verbose mode). The logs are attached.


Version-Release number of selected component (if applicable):
gnome-packagekit-2.28.3-3.el6.x86_64
PackageKit-gtk-module-0.5.8-19.el6.x86_64
PackageKit-gtk-module-0.5.8-19.el6.i686
PackageKit-glib-0.5.8-19.el6.x86_64
PackageKit-gstreamer-plugin-0.5.8-19.el6.x86_64
PackageKit-yum-plugin-0.5.8-19.el6.x86_64
PackageKit-device-rebind-0.5.8-19.el6.x86_64
PackageKit-yum-0.5.8-19.el6.x86_64
PackageKit-0.5.8-19.el6.x86_64


How reproducible:


Steps to Reproduce:
1. Enable next RHEL6 (6.0->6.1 or 6.1->6.2) channels and wait until packagekit refreshes.
2. Start an upgrade using the application gpk-update-viewer.
3. At a given time the application goes blank.
4. If you check the verbose log of packagekitd and gpk-update-viewer, will notice that it happens right after the signal "repo-list-changed" be triggered.
  

Actual results:
The window of the application goes blank, but the update continues behind.


Expected results:
The window of the application should continue showing the packages updates status and the overall status.


Additional info:
The log is from updates of EL 6.0 to EL 6.1.

Comment 2 RHEL Product and Program Management 2011-10-11 05:28:39 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Rodrigo Trujillo 2011-10-17 04:41:59 UTC
Created attachment 528443 [details]
Screenshots of the blank window.

Three screenshots of the blank window.
The package YUM was being installed.

Comment 4 Richard Hughes 2012-02-02 09:57:27 UTC
(In reply to comment #3)
> The package YUM was being installed.

Hi Rodrigo. Did you ever reproduce this on any other package than the yum package? PackageKit has code that deals with itself, yum and the gnome frontend being upgraded, and it could be this code that caused a refresh in the middle of the transaction.

Thanks,

Richard.

Comment 5 Grant Williamson 2012-02-16 15:33:15 UTC
Created attachment 562525 [details]
gpk-update-viewer -v

Upgrade from our el6.0 to el6.2 bug can be seen at 08:50
" not found ID for package"

Comment 6 Grant Williamson 2012-02-16 15:34:18 UTC
Created attachment 562526 [details]
pkmon of upgrade process

pkmon of upgrade from our el6.0 to 6.2

Comment 7 Grant Williamson 2012-02-16 15:34:46 UTC
Change to 6.2.

Comment 8 Grant Williamson 2012-02-20 17:53:59 UTC
Tested patch provided by Richard Hughes.

completed same test, no blank window.

Comment 9 Richard Hughes 2012-02-20 17:59:21 UTC
Upstream patch:

commit c817792b7e1fdc81b8a423b80b888265176bba37
Author: Richard Hughes <richard@hughsie.com>
Date:   Mon Feb 20 17:57:15 2012 +0000

    Do not attempt to refresh the updates list when a transaction is running
    
    If a package adds or removes a .repo file during a transaction, the
    ::RepoListChanged() signal gets sent from PackageKit. If a tranaction is already
    running, then just ignore the signal and continue the transaction like normal.
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=744980

Comment 12 Suzanne Yeghiayan 2012-05-14 19:02:01 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 14 Richard Hughes 2012-08-02 13:50:27 UTC
Committed into rhel-6.4.

Comment 18 errata-xmlrpc 2013-02-21 07:47:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0280.html


Note You need to log in before you can comment on or make changes to this bug.