This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 745020 - disable libxl on non-x86 arches
disable libxl on non-x86 arches
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
16
s390x Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-11 04:25 EDT by Dan Horák
Modified: 2011-10-11 19:50 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-11 19:50:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2011-10-11 04:25:34 EDT
Description of problem:
libxl support needs to be explicitly disabled on non-x86 arches otherwise build fails with 
...
Processing files: libvirt-0.9.6-2.fc16.s390
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.cld2Hu
error: Directory not found: /builddir/build/BUILDROOT/libvirt-0.9.6-2.fc16.s390/var/log/libvirt/libxl
error: Directory not found: /builddir/build/BUILDROOT/libvirt-0.9.6-2.fc16.s390/var/run/libvirt/libxl
error: Directory not found: /builddir/build/BUILDROOT/libvirt-0.9.6-2.fc16.s390/var/lib/libvirt/libxl
+ umask 022
+ cd /builddir/build/BUILD
...

Version-Release number of selected component (if applicable):
libvirt-0.9.6-2.fc16

For full logs please see
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=470366
Comment 1 Laine Stump 2011-10-11 11:15:04 EDT
Dan,

I see you've already fixed it in both F16 and rawhide git. Thanks for correcting this oversight. To make sure this change doesn't get lost in a future update from upstream, could you post a patch to libvir-list@redhat.com? (since libvirt.spec is a generated file, the file to patch will be libvirt.spec.in)
Comment 3 Eric Blake 2011-10-11 19:50:41 EDT
Now upstream; next rebase (0.9.7) will get it automatically, and current libivrt.spec can point back to this upstream commit if we release 0.9.6-4.

commit 099dc93b7c39dd84fe2ae573f3cb782dd0051028
Author: Dan Horák <dan@danny.cz>
Date:   Tue Oct 11 17:30:50 2011 +0200

    disable xenlight for non-Xen platforms
    
    when building libvirt in Fedora/s390x I've found that xenlight needs to
    be explicitly disabled in the spec file. Configure properly sets the
    library as non-existent, but the %files section still wants to package
    the 3 /var/*/libvirt/libxl directories. See also
    https://bugzilla.redhat.com/show_bug.cgi?id=745020

Note You need to log in before you can comment on or make changes to this bug.