Bug 74503 - gcc is unable to rebuild itself
gcc is unable to rebuild itself
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-25 10:28 EDT by Leonid Kanter
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version: 3.2-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 14:09:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nohup.out produced by rpmbuild -ba gcc32.spec (35.69 KB, application/x-bzip2)
2002-09-25 10:33 EDT, Leonid Kanter
no flags Details
A patch (820.99 KB, patch)
2002-09-25 10:57 EDT, hjl
no flags Details | Diff
BUILD/gcc-3.2-20020903/obj-i386-asplinux-linux/i386-asplinux-linux/libstdc++-v3/config.log (149.29 KB, text/plain)
2002-09-25 11:26 EDT, Leonid Kanter
no flags Details
config.log from clean psyche box (146.40 KB, text/plain)
2002-09-25 11:35 EDT, Leonid Kanter
no flags Details

  None (edit)
Description Leonid Kanter 2002-09-25 10:28:32 EDT
Description of Problem:

gcc is unable to rebuild itself. rpmbuild --ba gcc32.spec finished with errors

Version-Release number of selected component (if applicable):

gcc-3.2-7

How Reproducible:

always

Steps to Reproduce:
1. install Psyche with development
2. satisfy gcc build dependency (dejagnu)
3. start rpm --rebuild gcc-3.2-7.src.rpm

Actual Results:

Error building package

Expected Results:

It must rebuild itself cleanly

Additional Information:
	
Reproduced on two boxes
Comment 1 Leonid Kanter 2002-09-25 10:33:14 EDT
Created attachment 77204 [details]
nohup.out produced by rpmbuild -ba gcc32.spec
Comment 2 hjl 2002-09-25 10:55:50 EDT
It is a known problem.
Comment 3 hjl 2002-09-25 10:57:49 EDT
Created attachment 77205 [details]
A patch
Comment 4 Jakub Jelinek 2002-09-25 11:05:26 EDT
That's not true.
It is a known problem that the patch I put in doesn't work with --enable-clocale=generic
(and that is what I've fixed in CVS).
But on Psyche it uses clocale gnu, not generic, as glibc is recent enough
and has the necessary bugfixes.
So I'm really interested in seeing libstdc++-v3's config.log to see what's
going on and why it chose clocale generic, not gnu.
Comment 5 Leonid Kanter 2002-09-25 11:26:16 EDT
Created attachment 77206 [details]
BUILD/gcc-3.2-20020903/obj-i386-asplinux-linux/i386-asplinux-linux/libstdc++-v3/config.log
Comment 6 Leonid Kanter 2002-09-25 11:31:07 EDT
sorry, it was from wrong box, but it's no matter
Comment 7 Jakub Jelinek 2002-09-25 11:32:53 EDT
Looks like you don't have german locale installed. The test needs it.
Comment 8 Leonid Kanter 2002-09-25 11:35:08 EDT
Created attachment 77207 [details]
config.log from clean psyche box
Comment 9 Leonid Kanter 2002-09-25 11:39:03 EDT
Hmm installer doesn't install German locale because I selected only Russian and
Ukrainian locales during installation. Let me rpm -i --force glibc-common and
retry...
Comment 10 Leonid Kanter 2002-09-25 13:18:37 EDT
Yes, I installed full set of glibc locales and rebuilt gcc rpm successfully.

Note You need to log in before you can comment on or make changes to this bug.