Bug 745081 - libgphoto2 - FTBFS on Fedora 15
libgphoto2 - FTBFS on Fedora 15
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libgphoto2 (Show other bugs)
15
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15FTBFS F16FTBFS
  Show dependency treegraph
 
Reported: 2011-10-11 06:59 EDT by Jiri Kastner
Modified: 2013-07-02 19:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-06 19:00:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Kastner 2011-10-11 06:59:02 EDT
Description of problem:
fails to build from source on unpackaged /usr/lib{,_64}/libgphoto2/print-camera-list, which is used after build to create udev rules, but 

Version-Release number of selected component (if applicable):
libgphoto2-2.4.10.1-1.fc15.src.rpm (2.4.11 from fc16/rawhide too)

How reproducible:
always

Steps to Reproduce:
1. download src.rpm
2. mock rebuild libgphoto2-2.4.10.1-1.fc15.src.rpm
3. check build.log
  
Actual results:
DEBUG: Checking for unpackaged file(s): /usr/lib/rpm/check-files /builddir/build/BUILDROOT/libgphoto2-2.4.10.1-1.fc15.x86_64
DEBUG: error: Installed (but unpackaged) file(s) found:
DEBUG:    /usr/lib64/libgphoto2/print-camera-list
DEBUG:     Installed (but unpackaged) file(s) found:
DEBUG:    /usr/lib64/libgphoto2/print-camera-list
DEBUG: RPM build errors:
DEBUG: Child returncode was: 1


Expected results:
rpm built

Additional info:
http://jkastner.fedorapeople.org/libgphoto2-2.4.10.1-2.fc15.0.arm1/ - successful build
http://jkastner.fedorapeople.org/libgphoto2-2.4.10.1-1.fc15/ - failed one
Comment 1 Jindrich Novy 2011-10-12 09:00:48 EDT
Just removed the print-camera-list from %{_libdir}. New packages will occur in F15 together with upcoming updates.
Comment 2 Henrik Nordström 2011-10-13 02:34:40 EDT
F15 build failed with

RPM build errors:
    File not found: /builddir/build/BUILDROOT/libgphoto2-2.4.11-1.fc15.i386/lib/udev/check-mtp-device
Comment 3 Henrik Nordström 2011-10-25 16:35:53 EDT
Any progress on fixing the F15 build of libgphoto2? the arm secondary arch is still missing libgphoto2 due to this.
Comment 4 Jindrich Novy 2011-10-26 04:20:35 EDT
It should be fixed now. The question is how the first f15 build of 2.4.11 could end up as successful...
Comment 5 Henrik Nordström 2011-10-26 07:00:26 EDT
Thanks!

2.4.11 have not been built for F15 before according to Koji.

Note You need to log in before you can comment on or make changes to this bug.