Bug 745196 - Automatic partitioning error
Summary: Automatic partitioning error
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-11 15:48 UTC by Jakub Hrozek
Modified: 2014-09-30 23:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-14 12:54:43 UTC
Type: ---


Attachments (Terms of Use)
the error message (16.33 KB, image/png)
2011-10-11 15:48 UTC, Jakub Hrozek
no flags Details
Anaconda logs + output of /proc/partitions and fdisk from inside the VM (12.50 KB, application/x-gzip)
2011-10-11 15:49 UTC, Jakub Hrozek
no flags Details

Description Jakub Hrozek 2011-10-11 15:48:17 UTC
Created attachment 527483 [details]
the error message

Description of problem:
When installing F16 Beta VM using a kickstart, partitioning fails suggesting that there's no space. The VM disk image is about 5GB though.

Version-Release number of selected component (if applicable):
16.20

How reproducible:
always

Actual results:
error message, see attached screenshot

Expected results:
install

Additional info:
The kickstart partitioning looks something like:
part /boot --fstype ext3 --size=150
part pv.01 --size=1024 --grow
volgroup vg_root pv.01
logvol swap --vgname=vg_root --fstype swap --name=lv_swap --recommended
logvol  /  --vgname=vg_root  --size=1024 --grow  --name=lv_root

I tried making the swap smaller as well to free more space for the root volume, but no good

Comment 1 Jakub Hrozek 2011-10-11 15:49:15 UTC
Created attachment 527484 [details]
Anaconda logs + output of /proc/partitions and fdisk from inside the VM

Comment 2 Jakub Hrozek 2011-10-11 15:56:31 UTC
(In reply to comment #0)
> Description of problem:
> When installing F16 Beta VM using a kickstart, partitioning fails suggesting
> that there's no space. The VM disk image is about 5GB though.

FWIW, I also retried with a 10GB image, which ought to be enough for everyone, but I got the same error.

Comment 3 Ales Kozumplik 2011-10-14 12:54:43 UTC
Your error is not about insufficient disk space. In Fedora 16 there needs to be a biosboot partition specified, see the information in the yellow box:

http://fedoraproject.org/wiki/Anaconda/Kickstart#bootloader

Adding 
part biosboot --fstype=biosboot --size=1

to your kickstart should do the trick.

Closing as not a bug.


Note You need to log in before you can comment on or make changes to this bug.