Bug 7452 - --prefix option does not work on rpm
--prefix option does not work on rpm
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-30 15:20 EST by gperry
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-11 12:01:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gperry 1999-11-30 15:20:05 EST
I tried to use the --prefix option to install a relocatable package in
another directory.  When I did this, it told me I could not use --prefix
and --relocate on the same line.  I did not use --relocate, so this is the
bug.  I did use --relocate to work around the problem, but this requires
querying the package to find the default home directory for the package,
and then including this directory on the rpm command line.
Comment 1 Jeff Johnson 2000-01-11 11:33:59 EST
What version of rpm? I believe this is fixed in rpm-3.0.2 and later.
Comment 2 gperry 2000-01-11 11:47:59 EST
"rpm --version" tells me it is 3.0.  Since there is a workaround, this is not
critical.  What is the best or easiest way for me to get 3.0.2 of rpm?
Comment 3 Jeff Johnson 2000-01-11 12:01:59 EST
The latest release rpm-3.0.3 is available from ftp.rpm.org, as are other,
earlier releases. There should also be errata releases of rpm-3.0.2 and
earlier available from any mirror that has Red Hat updates.

There's also rpm-3.0.4 in Raw Hide if you're brave :-)

Note You need to log in before you can comment on or make changes to this bug.