Bug 745236 - JON3 BETA2 ...WARN messages after clean install, drift related
JON3 BETA2 ...WARN messages after clean install, drift related
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: drift (Show other bugs)
4.1
Unspecified Unspecified
low Severity medium (vote)
: ---
: JON 3.0.0,RHQ 4.3.0
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: 707225
  Show dependency treegraph
 
Reported: 2011-10-11 14:26 EDT by Mike Foley
Modified: 2012-02-07 14:17 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:17:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
WARN message in server log (367.54 KB, application/octet-stream)
2011-10-11 14:26 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2011-10-11 14:26:25 EDT
Created attachment 527516 [details]
WARN message in server log

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
WARN ing messages in server log

Expected results:
install without WARNings or ERRORs

Additional info:
2011-10-11 14:13:24,736 WARN  [org.jboss.ejb3.mdb.MessagingContainer] Could not find the queue destination-jndi-name=queue/DriftFileQueue
2011-10-11 14:13:24,737 WARN  [org.jboss.ejb3.mdb.MessagingContainer] destination not found: queue/DriftFileQueue reason: javax.naming.NameNotFoundException: DriftFileQueue not bound
2011-10-11 14:13:24,737 WARN  [org.jboss.ejb3.mdb.MessagingContainer] creating a new temporary destination: queue/DriftFileQueue
2011-10-11 14:13:24,744 INFO  [org.jboss.mq.server.jmx.Queue.DriftFileQueue] Bound to JNDI name: queue/DriftFileQueue
2011-10-11 14:13:24,765 WARN  [org.jboss.ejb3.mdb.MessagingContainer] Could not find the queue destination-jndi-name=queue/DriftChangesetQueue
2011-10-11 14:13:24,766 WARN  [org.jboss.ejb3.mdb.MessagingContainer] destination not found: queue/DriftChangesetQueue reason: javax.naming.NameNotFoundException: DriftChangesetQueue not bound
2011-10-11 14:13:24,766 WARN  [org.jboss.ejb3.mdb.MessagingContainer] creating a new temporary destination: queue/DriftChangesetQueue
Comment 1 Jay Shaughnessy 2011-11-03 16:35:02 EDT
The issue here is that the drift message driven beans were not being
explicitly deployed via a service xml file in the AS' deploy directory.
We currently had an alert-cache-service.xml deploying the alert cache
mdb. So now replacing that with rhq-mdb-service.xml to create a
consolidated service file deploying rhq mdbs.

Test notes:
This actually changes the installer because the deployed file name
has changed.  So test by actually performing an install, making sure
the server start, runs appropriately for simple drift and alerting
use case, and that the startup warnings have gone away.
Comment 2 Jay Shaughnessy 2011-11-03 17:56:23 EDT
master         commit: 2250f71c6defc4479de2eb197d6171b1e2365c5b
release_jon3.x commit: 8ed0c61658e7da3324a1dc0b64724d882b878850
Comment 3 Mike Foley 2011-11-04 16:45:45 EDT
spot checked drift, alerts, and reviewed server logs.
Comment 4 Mike Foley 2012-02-07 14:17:47 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.