Bug 745242 - Fallback to import the private keys as PKCS#8 if regular import fails
Summary: Fallback to import the private keys as PKCS#8 if regular import fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnutls
Version: 6.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: Jiri Jaburek
URL:
Whiteboard:
: 798054 (view as bug list)
Depends On:
Blocks: 772279 782183 836160 840699
TreeView+ depends on / blocked
 
Reported: 2011-10-11 18:41 UTC by Erinn Looney-Triggs
Modified: 2018-11-30 22:30 UTC (History)
2 users (show)

Fixed In Version: gnutls-2.8.5-8.el6
Doc Type: Enhancement
Doc Text:
Feature: GNUTLS now allows loading also private keys in PKCS#8 format if application calls gnutls_x509_privkey_import(). Reason: If a private key is in the PKCS#8 format applications which use gnutls_x509_privkey_import() would previously fail to load it. Result (if any):
Clone Of:
Environment:
Last Closed: 2013-02-21 10:33:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0425 normal SHIPPED_LIVE gnutls bug fix update 2013-02-20 20:49:20 UTC

Description Erinn Looney-Triggs 2011-10-11 18:41:59 UTC
Description of problem:
This is kind of an interesting problem that crosses a couple of programs and is not specifically rsyslog related, though rsyslog probably shouldn't core dump on the error. 

The issue is when using rsyslog with TLS enabled, if the private key is held in the PKCS#8 format, rsyslog will core dump with the following error:

unexpected GnuTLS error -207 in nsd_gtls.c:197: Base64 unexpected header error.

Now as I said the issue only occurs with PKCS#8 formatted keys, you can find more info on that format here:
http://www.openssl.org/docs/apps/pkcs8.html

It looks like this problem has been solved in gnutls > 2.12, as referenced here:
https://lists.gnu.org/archive/html/help-gnutls/2011-10/msg00005.html

I doubt an upgrade to a different version of gnutls is feasible but perhaps a back port of said feature could help. 

For rsyslog it probably shouldn't just core dump on the issue. A bug about this is open here:
http://bugzilla.adiscon.com/show_bug.cgi?id=290

If you are interested this issue all arose because certmaster switched to using PKCS#8 format in RHEL 6. I know certmaster is unsupported, and I have yet to find out if the switch was intentional or not, but there we are.

Version-Release number of selected component (if applicable):
gnutls-2.8.5-4.el6.x86_64
rsyslog-4.6.2-9.el6.x86_64
rsyslog-gnutls-4.6.2-9.el6.x86_64

How reproducible:
Use a PKCS#8 formatted pricate key

  
Actual results:
Core dump

Expected results:
Perhaps an error?

Comment 2 RHEL Product and Program Management 2011-10-11 19:09:14 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Tomas Mraz 2011-10-11 19:12:58 UTC
This is the gnutls commit for reference:
http://git.savannah.gnu.org/gitweb/?p=gnutls.git;a=commitdiff;h=f780425c751c6e31d26985e629d1abf3886168d3;hp=1d303703e4f4ab16b090d4506c68be5476ecb376

The core dump must be solved on the rsyslog side.

Also please use the regular support channels to request the bug to be fixed. It is necessary for proper prioritizing.

Comment 4 Erinn Looney-Triggs 2011-10-11 19:30:24 UTC
Case #00513502 has been open for two months before I finally gave up and opened this BZ. Hopefully this will allow you to prioritize etc.

-Erinn

Comment 5 Tomas Mraz 2011-10-12 06:11:03 UTC
The core dump fix is the bug 727380 for reference.

Comment 7 Suzanne Yeghiayan 2012-02-14 23:17:16 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 8 Tomas Mraz 2012-02-28 21:08:33 UTC
*** Bug 798054 has been marked as a duplicate of this bug. ***

Comment 9 Erinn Looney-Triggs 2012-02-28 21:13:30 UTC
Ha, forgot I filed this bug, so filed another one. Ah, how funny.

-Erinn

Comment 17 errata-xmlrpc 2013-02-21 10:33:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0425.html


Note You need to log in before you can comment on or make changes to this bug.