Bug 745282 - [RFE] Support to use virt-filesystems with remote libvirt systems
[RFE] Support to use virt-filesystems with remote libvirt systems
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs (Show other bugs)
6.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
: FutureFeature, Triaged
Depends On:
Blocks: 912193 1070166 1127233
  Show dependency treegraph
 
Reported: 2011-10-11 17:19 EDT by Chris Williams
Modified: 2014-08-06 08:42 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 05:00:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Williams 2011-10-11 17:19:26 EDT
Who is the customer behind the request?
    Account name: 540054
    Customer segment: 2
    TAM/SRM customer yes/no
: Cynthia Baldwin, SRM
    VHT score: 2
What is the nature and description of the request?

Ability to use virt-filesystems with remote systems when it is connected using virt-filesystems -c <remote URI> -d domainname. Even though we are able to connect with remote libvirt systems, virt-v2v looks for VM images in the local system instead of remote system to the filesystem details

Why does the customer need this? (List the business requirements here)

Customer is looking for this feature because he do not want copy the image files to local systems before executing virt-filesystems -c <remote URI>.

How would the customer like to achieve this? (List the functional requirements here)

virt-filesystems -c <remote URI> -d domname should fetch the information from the image file the the VM uses on the remote system.

For each functional requirement listed in question 4, specify how Red Hat  and the customer can test to confirm the requirement is successfully  implemented.

The virt-filesystems will list information of remote VM filesystem details when connected using a remote URI. Currently it fails with the error message, "no such file or directory" as it is looking for the image file in the local system

Is there already an existing RFE upstream or in Red Hat bugzilla?

Not able to find one.

How quickly does this need resolved? (desired target release)

RHEL 6.3?

Does this request meet the RHEL Bug and Feature Inclusion Criteria

yes
    List the affected packages

libguestfs

Would the customer be able to assist in testing this functionality if implemented?
yes
Comment 6 Richard W.M. Jones 2011-10-17 11:40:30 EDT
Reassigning this to libguestfs.
Comment 10 Richard W.M. Jones 2013-07-30 06:05:08 EDT
This bug had the wrong product (because of my mistake) so it didn't
appear on my scope.

This is fixed in RHEL 7.0.  You can access remote systems using
the nbd protocol, ie:

virt-filesystems -a nbd://remote.example.com

For RHEL 6 it's not likely we will add this extra functionality
since it's significantly complicated.
Comment 12 Richard W.M. Jones 2013-09-27 05:00:27 EDT
Closing - see comment 10.  Remote functionality using NBD and some
other transports will be available in RHEL 7.

Note You need to log in before you can comment on or make changes to this bug.