Red Hat Bugzilla – Bug 74530
should require gnome-libs > 1:1.2.11 not 1.2.11
Last modified: 2015-01-07 19:00:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827
Description of problem:
I think nautilus should require gnome-libs > 1:1.2.11 not gnome-libs > 1.2.11 as
it currently does since the old gnome-libs from redhat-7.3 provided gnome-libs =
1:1.2.8 which is clearly greater than 1.2.11 but not greater than 1:1.2.11 so it
satisfies the requirement when it shouldn't (I'm assuming).
BTW, this type of problem exists in more than just this package. If you choose
to do something about this (and I think you should) then I'll submit more bugs
of this ilk.
Is there someone at redhat that deals with system wide problems like this, or
should I submit bug reports for each of the packages affected by problems like this?
Bug reports for each affected package are the way to go so things don't get lost.
In this particular case, nautilus 2.0 shouldn't require gnome-libs 1.2.x at all,
regardless of version...
Nautilus 2 (shipped since RH8) shouldn't depend on gnome-libs at all (since
that's a gnome1 library). If you have other apps that have bad dependencies like
these, please report them.