Bug 74530 - should require gnome-libs > 1:1.2.11 not 1.2.11
should require gnome-libs > 1:1.2.11 not 1.2.11
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-25 21:28 EDT by Jim Radford
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 11:55:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Radford 2002-09-25 21:28:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
I think nautilus should require gnome-libs > 1:1.2.11 not gnome-libs > 1.2.11 as
it currently does since the old gnome-libs from redhat-7.3 provided gnome-libs =
1:1.2.8 which is clearly greater than 1.2.11 but not greater than 1:1.2.11 so it
satisfies the requirement when it shouldn't (I'm assuming).

BTW, this type of problem exists in more than just this package.  If you choose
to do something about this (and I think you should) then I'll submit more bugs
of this ilk.

Is there someone at redhat that deals with system wide problems like this, or
should I submit bug reports for each of the packages affected by problems like this?
Comment 1 Havoc Pennington 2002-09-25 22:25:34 EDT
Bug reports for each affected package are the way to go so things don't get lost.

In this particular case, nautilus 2.0 shouldn't require gnome-libs 1.2.x at all,
regardless of version...
Comment 2 Alexander Larsson 2003-01-16 11:55:54 EST
Nautilus 2 (shipped since RH8) shouldn't depend on gnome-libs at all (since
that's a gnome1 library). If you have other apps that have bad dependencies like
these, please report them.

Note You need to log in before you can comment on or make changes to this bug.