Bug 74532 - cfengine needed
cfengine needed
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: distribution (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: RHEL Product and Program Management
Daniel Riek
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-25 22:35 EDT by Joshua Jensen
Modified: 2008-08-25 12:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-25 12:30:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2002-09-25 22:35:28 EDT
Not sure where to file this...

Big, enterprise shops really, really want cfengine.  Please include it in the
next release of AS.
Comment 1 Bill Nottingham 2002-10-25 16:44:53 EDT
Probably not at this point.
Comment 2 Joshua Jensen 2002-12-17 18:07:50 EST
I re-opened this because it appears to be very important several of our
customers.  I've asked them to add their input here, so that we can accurately
measure their desire for cfengine in Red Hat Linux.
Comment 3 Pekka Savola 2002-12-18 01:23:57 EST
We don't use AS version, but I'll still add my 5 cents here.

I think cfengine is very useful in larger deployments, but it requires a bit to
get started with.

As having maintained RPM's of cfengine for our deployment for 3.5 years, it can
be said it's sometimes a bit painful: tools required to build it properly vary a
bit.

Larger deployments likely have to add more of their customized RPM's _anyway_
(we certainly have to), so shipping cfengine is not likely a huge value in
itself (compared to having pointers to a nice package added e.g. in rhcontrib)

I'm not sure of the added value of cfengine in RHL, _unless_ it would be used by
RHL maintainers and support folks -- ie. it wouldn't be just one of those "dead
weight" packages that were added because folks asked for it.
Comment 4 Ali-Reza Anghaie 2002-12-18 03:47:02 EST
I think cfengine is definately something to keep an eye on. I work for Pratt & 
Whitney (www.pw.utc.com) right now and we've got a number of setups that could 
benefit from it. I could see some arguments as how to package it for AS vs. 
desktop. Cheers, -Ali 
Comment 5 Karsten Thygesen 2003-11-19 05:48:48 EST
Here at our organization, we have a mixture of Sun, HP-UX, Digital, 
FreeBSD and recently started to migrate to RedHat AS/itanium. We use 
cfengine on all other servers and is very dependent on this setup. 

I was quite disappointed to discover, that is was not included in AS 
- cfengine is a must for most enterprises. 

Well - I have to recompile myself, but the idea with teaming up with 
redhat/AS was to skip this step and get support on stuff like this...

Karsten
Comment 6 Suzanne Hillman 2003-12-15 15:38:45 EST
Internal RFE bug #112186 entered - will be considered for future releases.
Comment 7 Joshua Jensen 2005-12-28 11:11:08 EST
???

Two Year Ping!!!
Comment 8 nathan r. hruby 2005-12-28 11:27:01 EST
Errr...
- cfengine is already in Fedora Extras

- Why would this bug be shifted to Fedora, as I belive it's still a vaild buglet
for RHEL?  We use RHEL and cfengine and not having to maintain the packages
would be nice (and yes, cfengine is much better then current RHN functionality :)
Comment 9 Joshua Jensen 2006-08-03 15:11:51 EDT
Hello?  Any response from Red Hat?
Comment 10 nathan r. hruby 2007-08-11 12:29:33 EDT
cfengine (and puppet) are in EPEL now which I think is "close enough"
http://download.fedora.redhat.com/pub/epel/4/SRPMS/repoview/cfengine.html

Comment 11 Joshua Jensen 2007-08-13 12:01:28 EDT
yes... good enough. Thank you!
Comment 12 Joshua Jensen 2008-03-14 15:09:09 EDT
bugzilla won't let me resolve this... but feel free to close it please!
Comment 13 Joshua Jensen 2008-06-18 18:55:07 EDT
please close this issue
Comment 15 RHEL Product and Program Management 2008-08-25 12:30:36 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.