Bug 745483 - Pictures within pdf files are displayed incorrectly
Summary: Pictures within pdf files are displayed incorrectly
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: epdfview (Show other bugs)
(Show other bugs)
Version: 16
Hardware: All Linux
unspecified
urgent
Target Milestone: ---
Assignee: Michal Schmidt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-12 13:49 UTC by Heiko Adams
Modified: 2011-11-05 01:34 UTC (History)
3 users (show)

Fixed In Version: epdfview-0.1.8-5.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-05 01:34:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My CV which isn't displayed properly (335.55 KB, application/pdf)
2011-10-12 13:49 UTC, Heiko Adams
no flags Details

Description Heiko Adams 2011-10-12 13:49:12 UTC
Created attachment 527704 [details]
My CV which isn't displayed properly

Description of problem:
When taking a look into my cv-pdf generated with ePDFView I noticed that my photo looks like the photo's negative.

Version-Release number of selected component (if applicable):
poppler-utils-0.18.0-1.fc16.i686
poppler-0.18.0-1.fc16.i686
poppler-glib-0.18.0-1.fc16.i686
poppler-data-0.4.4-2.fc15.noarch

How reproducible:
allways

Steps to Reproduce:
1. generate a pdf which contains a photo
2. open the pdf with ePDFView
3.
  
Actual results:
The photo looks like the photo's negative

Expected results:
The photo should be displayed correctly

Additional info:
When opening the same pdf with Adobe reader everything looks fine

Comment 1 Rex Dieter 2011-10-15 15:58:39 UTC
Which app did you use to view?

I just tested okular on f16/x86_64, and it seems to display ok.

Comment 2 Heiko Adams 2011-10-15 16:12:30 UTC
I'm using ePDFView (epdfview-0.1.8-4.fc16.i686)

Comment 3 Heiko Adams 2011-10-17 11:37:04 UTC
It seems to be a bug with ePDFView because xpdf displays the pdf correct too

Comment 4 Michal Schmidt 2011-10-17 12:29:38 UTC
Looks like upstream SVN has a fix for this:
http://trac.emma-soft.com/epdfview/changeset/367/trunk

Comment 5 Fedora Update System 2011-10-19 09:49:07 UTC
epdfview-0.1.8-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/epdfview-0.1.8-5.fc16

Comment 6 Fedora Update System 2011-10-20 02:26:02 UTC
Package epdfview-0.1.8-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing epdfview-0.1.8-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14631
then log in and leave karma (feedback).

Comment 7 Heiko Adams 2011-11-01 22:38:05 UTC
Problem solved :-)

Comment 8 Fedora Update System 2011-11-05 01:34:43 UTC
epdfview-0.1.8-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.