Bug 74553 - alternatives not correcting for sendmail(1) man page
alternatives not correcting for sendmail(1) man page
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: postfix (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-26 12:19 EDT by Chris Ricker
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 06:46:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-09-26 12:19:30 EDT
On RHL 8, if both sendmail and postfix are installed,

$ man sendmail

pulls up the Postfix sendmail man page, even when alternatives has sendmail
configured as the preferred MTA.

The basic problem is that Postfix supplies /usr/share/man/man1/sendmail.1.gz,
while Sendmail supplies /usr/share/man/man8/sendmail.8.gz; since section 1 is
before section 8 in the man section search path, the Postfix man page comes up
instead of the Sendmail man page.

Ideally, alternatives would correct for this, perhaps by something like:

sendmail supplies /usr/share/man/man8/sendmail.sendmail.8.gz
postfix supplies /usr/share/man/man1/sendmail.postfix.1.gz

alternatives creates /usr/share/man/man1/sendmail.1.gz ->
/usr/share/man/man1/sendmail.postfix.1.gz symlink if Postfix is the preferred
MTA, and creates /usr/share/man/man8/sendmail.8.gz ->
/usr/share/man/man8/sendmail.sendmail.8.gz symlink if Sendmail is the preferred MTA

(obviously, this requires fixes to the postfix rpm as well, but bugzilla won't
let me file the same bug against two packages)
Comment 1 rm0 2002-11-29 08:37:43 EST
I was goiung to report the same bug against the sendmail packages shipped with 
RHL 7.3

Regards,
Comment 2 Chris Ricker 2002-12-23 11:30:26 EST
still true in phoebe public beta
Comment 3 Thomas Woerner 2004-01-28 09:42:51 EST
This is a postfix error.
Comment 4 Chris Ricker 2004-01-28 10:05:51 EST
It's a both error -- it can't be fixed just in the postfix RPM, or
just in the sendmail rpm
Comment 5 John Dennis 2004-02-24 18:52:48 EST
I added this to the postfix spec:

--slave %{_mandir}/man8/sendmail.8.gz mta-sendmailman
%{_mandir}/man1/sendmail.1.gz \

I think you'll need to add this to the sendmail spec:

--slave %{_mandir}/man8/sendmail.8.gz mta-sendmailman
%{_mandir}/man8/sendmail.8.gz \

I don't think you need to rename the man page to append ".sendmail"
because the sendmail and postfix versions of the man page live in
different directories and hence have unique paths. I do realize that
when linked via alternatives this will cause the postfix version of
the sendmail man page which by default lives in section 8 to display
with section 1 in the title, but I'm not losing sleep over this :-)

I'm assigning this to you Thomas so you can update sendmail.spec.
Comment 6 Thomas Woerner 2004-03-16 04:50:42 EST
This is not the correct solution. If sendmail asns postfix are both
installed and you are calling man sendmail you are netting the '
Postfix to Sendmail compatibility interface' man page regadless if you
are using postfix or sendmail as mta. This is a big problem. If you
call man, it finds the man page in man1 prior to man8.

The correct solution is to rename %{_mandir}/man1/sendmail.1.gz to
%{_mandir}/man1/sendmail.1.gz.postfix and to put it in alternatives.

By the way: This problem still occurs on fc2 with postfix-2.0.16-13.
Comment 7 John Dennis 2004-03-16 19:50:59 EST
Good catch Thomas! O.K. this is what I did:

--slave %{_mandir}/man8/sendmail.8.gz mta-sendmailman
%{_mandir}/man1/sendmail.postfix.1.gz

note that both sendmail's and postfix's man page will point to whats
in man8 now. You will have to add this to sendmail's alternatives
otherwise there is going to be a collision on
/usr/share/man/man8/sendmail.8.gz.

This change first appears in postfix-2.0.18-2 which is currently
building in dist-fc2.
Comment 8 Thomas Woerner 2004-03-17 06:46:29 EST
Fixed in rwahide in rpm sendmail-8.12.11-4 or newer.

Note You need to log in before you can comment on or make changes to this bug.