Bug 74561 - evolution will not work with my imap mail server
evolution will not work with my imap mail server
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-26 13:37 EDT by Don Hardaway
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-09 21:54:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug output from eveolution-mail (3.98 KB, text/plain)
2002-10-14 23:46 EDT, Joe Cooper
no flags Details

  None (edit)
Description Don Hardaway 2002-09-26 13:37:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
When I choose imap for the mail server it does not load the folders i have on
the mail server.  I have done the same thing in mozilla's mail program and it
works properly. I have used evolution in past versions and it worked properly also.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.launch evolution
2.select mail accounts and then edit my account
3.select imap for the incoming server
	

Actual Results:  does nothing

Expected Results:  should show the folders on the imap server.

Additional info:
Comment 1 Jeremy Katz 2002-10-01 18:54:20 EDT
If you run `CAMEL_VERBOSE_DEBUG=1 evolution-mail` from a terminal, wait 5-10
seconds and then start evolution, what sort of output do you get in the terminal
when you try to see your imap folders?

Also, what is the server side running?
Comment 2 Don Hardaway 2002-10-01 19:30:37 EDT
I tried it and in the terminal window nothing comes back but a carriage return
to the next line. I don't know what the server is running but i can tell you
that mozilla mail works perfectly with it.
Comment 3 Jeremy Katz 2002-10-01 23:06:24 EDT
Yes, you won't get any output in the terminal with evolution-mail running until
after evolution starts and tries to do mail operations -- if you don't get
anything then, you probably need to let the evolution-mail process wait longer
before starting evolution.
Comment 4 Don Hardaway 2002-10-02 10:27:43 EDT
When I open evolution and send/get messages it attempts to get them and then
comes back with no messages. In prior releases this process immediately
retrieved mail as it does now with mozilla-mail. If I edit the account and
change the server from imap to pop then it will retrieve messages even though it
is a imap mail server. What would you like to do in order to debug this?
Comment 5 Jeremy Katz 2002-10-05 10:21:41 EDT
And you don't get any output from the evolution-mail process?  Do you get output
from it when you switch to POP?
Comment 6 Don Hardaway 2002-10-06 18:06:13 EDT
That is correct.
Comment 7 Need Real Name 2002-10-11 14:20:59 EDT
I will just add that I had problems with evolution and IMAP as well.  It also 
would not load my inbox from /var/spool/mail and my IMAP 
folders /home/user/Mail.  

Returned to using Kmail and Mozilla Mail...both work fine.
Comment 8 Joe Cooper 2002-10-14 23:45:27 EDT
I have the same problem here.  Our server is Red Hat 7.2, fully up2date, running
the Red Hat imap package in SSL mode (imaps).

No problems in other clients.  I've attached the debug output from the command
mentioned, just in case it doesn't come from someone else.
Comment 9 Joe Cooper 2002-10-14 23:46:19 EDT
Created attachment 80424 [details]
Debug output from eveolution-mail
Comment 10 Need Real Name 2002-10-27 17:06:57 EST
Running Evolution against an IMAP server on the same machine / user also ends
uphogging CPU since it recursively follows a symbolic link from
~user/.openoffice/user/work -> ~user.

Mozilla mail in the same circumstances doesn't try to be clever...

System is a fresh install of RH8.0
Comment 11 Don Hardaway 2002-10-30 15:55:16 EST
Hello. Is anyone home. I would still like to get evolution working on my laptop.
Comment 12 Jeremy Katz 2003-02-09 21:54:35 EST
evolution 1.2.x in rawhide handles imap namespaces much more correctly according
to the imap rfcs, which should work around this problem.

Note You need to log in before you can comment on or make changes to this bug.