Bug 745634 - BUG: unable to handle kernel NULL pointer dereference at 0000000000000039 __sys_sendmsg
BUG: unable to handle kernel NULL pointer dereference at 0000000000000039 __s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:868039eb3f872712e31183ac616...
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2011-10-12 17:27 EDT by Iván Jiménez
Modified: 2012-05-14 13:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 13:57:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iván Jiménez 2011-10-12 17:27:21 EDT
libreport version: 2.0.6
abrt_version:   2.0.4.981
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.0-0.rc9.git0.0.fc16.x86_64 root=UUID=f9638177-85d2-4df0-a1f1-2cd03d82dc3f ro quiet rhgb SYSFONT=latarcyrheb-sun16 LANG=es_ES.UTF-8 KEYTABLE=es
comment:        it was waking up from hibernation
kernel:         undefined
reason:         BUG: unable to handle kernel NULL pointer dereference at 0000000000000039
time:           Tue Oct 11 20:55:59 2011

backtrace:
:BUG: unable to handle kernel NULL pointer dereference at 0000000000000039
:IP: [<ffffffff813c6364>] __sys_sendmsg+0x1bb/0x2ba
:PGD 2371e067 PUD 236d8067 PMD 0 
:Oops: 0000 [#1] SMP 
:CPU 1 
:Modules linked in: tcp_lp ppdev parport_pc lp parport fuse ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm arc4 snd_timer snd soundcore ath9k mac80211 ath9k_common ath9k_hw ath cfg80211 dell_laptop compal_laptop uvcvideo videodev media v4l2_compat_ioctl32 iTCO_wdt snd_page_alloc r8169 microcode rfkill i2c_i801 dcdbas joydev mii iTCO_vendor_support uinput uas ums_realtek usb_storage i915 drm_kms_helper drm i2c_algo_bit i2c_core video
:Pid: 825, comm: dbus-daemon Not tainted 3.1.0-0.rc9.git0.0.fc16.x86_64 #1 Dell Inc. Inspiron 1012/0P9MDV
:RIP: 0010:[<ffffffff813c6364>]  [<ffffffff813c6364>] __sys_sendmsg+0x1bb/0x2ba
:RSP: 0018:ffff880023727d88  EFLAGS: 00010246
:RAX: 0000000000000000 RBX: ffff880023727f18 RCX: 0000000000000002
:RDX: 0000000000000000 RSI: 0000000000000000 RDI: ffff880023727db8
:RBP: ffff880023727f08 R08: 000000007fffffff R09: 0000000001805b00
:R10: 00000000017f7a6d R11: 0000000000000293 R12: ffff88003b2de000
:R13: 00000000000000d5 R14: ffff880023727ea8 R15: 0000000000000000
:FS:  00007f0fa8c27800(0000) GS:ffff88003f300000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
:CR2: 0000000000000039 CR3: 0000000023710000 CR4: 00000000000006e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process dbus-daemon (pid: 825, threadinfo ffff880023726000, task ffff880023648000)
:Stack:
: 0000002800000000 00000020236d8010 0000000000004000 ffff880023727da8
: 000000000180f250 00000000000000a0 0000000001805b00 0000000000000035
: ffff8800236dd840 ffff88002edc4380 0000000000413010 0000000000000028
:Call Trace:
: [<ffffffff810440fa>] ? update_stats_wait_end+0x6d/0xaf
: [<ffffffff81045983>] ? set_next_entity+0x46/0x99
: [<ffffffff8100e00e>] ? read_cr0+0xe/0x12
: [<ffffffff8100e03a>] ? paravirt_write_msr+0x14/0x18
: [<ffffffff8100e75b>] ? __switch_to+0x141/0x220
: [<ffffffff81047f02>] ? finish_task_switch+0x49/0xba

smolt_data:
:
:
:General
:=================================
:UUID: 4de73fa6-0192-429e-9a84-878da558a6ba
:SO: Fedora release 16 (Verne)
:Nivel de ejecución por defecto: Unknown
:Idioma: es_CO.utf8
:Plataforma: x86_64
:BogoMIPS: 3325.00
:Fabricante de CPU: GenuineIntel
:Modelo de CPU: Intel(R) Atom(TM) CPU N450   @ 1.66GHz
:Paso del UCP: 10
:Familia de UCP: 6
:Número de Modelo de CPU: 28
:Número de CPUs: 2
:Velocidad del CPU: 1667
:Memoria del Sistema: 986
:Intercambio (swap) del Sistema: 1983
:Vendedor: Dell Inc.
:Sistema: Inspiron 1012 A10
:Factor de forma: Portable
:Kernel: 3.1.0-0.rc9.git0.0.fc16.x86_64
:SELinux Habilitado: 1
:Política de SELinux: targeted
:SELinux Obligado: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Dispositivos
:=================================
:(32902:10172:4136:1050) pci, None, PCI/ISA, NM10 Family LPC Controller
:(32902:40977:4136:1050) pci, i915, VIDEO, N10 Family Integrated Graphics Controller
:(32902:40978:4136:1050) pci, None, VIDEO, N10 Family Integrated Graphics Controller
:(32902:10192:4136:1050) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:4136:1050) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(32902:10200:4136:1050) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10202:4136:1050) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:9288:4136:1050) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(4332:33078:4136:1050) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10177:4136:1050) pci, ahci, STORAGE, N10/ICH7 Family SATA AHCI Controller
:(32902:10185:4136:1050) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4136:1050) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:40976:4136:1050) pci, agpgart-intel, HOST/PCI, N10 Family DMI Bridge
:(32902:10186:4136:1050) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10187:4136:1050) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:4136:1050) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:(5772:43:5772:516) pci, ath9k, NETWORK, AR9285 Wireless Network Adapter (PCI-Express)
:
:
:Información relacionada con el sistema de archivos
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 12901535 12046075 11915046 3276800 3171159 3171159
:/dev/sda5 /home ext4 4096 4096 24931454 24522081 23255637 6332416 6324362 6324362
:/dev/sda2 /boot ext4 1024 1024 495844 414557 388957 128016 127786 127786
:
Comment 1 Chuck Ebbert 2011-10-17 23:31:10 EDT
net/socket.c:1960:

        if (sock->file->f_flags & O_NONBLOCK)
                msg_sys->msg_flags |= MSG_DONTWAIT;

 sock->file is NULL

Also, the stack backtrace looks like total nonsense to me. Maybe memory got corrupted during the hibernate/resume cycle...
Comment 2 Dave Jones 2012-03-22 12:46:12 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 3 Dave Jones 2012-03-22 12:50:52 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 13:00:49 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Josh Boyer 2012-03-28 13:59:34 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.
Comment 6 Iván Jiménez 2012-03-28 16:44:44 EDT
(In reply to comment #5)
> [Mass hibernate bug update]
> 
> Dave Airlied has found an issue causing some corruption in the i915 fbdev after
> a resume from hibernate.  I have included his patch in this scratch build:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545
> 
> This will probably not solve all of the issues being tracked at the moment, but
> it is worth testing when the build completes.  If this seems to clear up the
> issues you see with hibernate, please report your results in the bug.

Sorry, I can't test the updated kernel because I'm using f17 now.
Comment 7 Josh Boyer 2012-03-28 16:51:55 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > [Mass hibernate bug update]
> > 
> > Dave Airlied has found an issue causing some corruption in the i915 fbdev after
> > a resume from hibernate.  I have included his patch in this scratch build:
> > 
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545
> > 
> > This will probably not solve all of the issues being tracked at the moment, but
> > it is worth testing when the build completes.  If this seems to clear up the
> > issues you see with hibernate, please report your results in the bug.
> 
> Sorry, I can't test the updated kernel because I'm using f17 now.

Should work fine there too.  There is very little difference between f16 and 17 kernels, and Dave's patch will likely go in both if it doesn't break things.

Note You need to log in before you can comment on or make changes to this bug.