Bug 74578 - mozilla doens't cross-build, and doesn't build for ppc
Summary: mozilla doens't cross-build, and doesn't build for ppc
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-26 20:35 UTC by Guy Streeter
Modified: 2016-02-10 01:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 20:56:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file changes (3.51 KB, patch)
2002-09-26 20:36 UTC, Guy Streeter
no flags Details | Diff
keep configure from trying to do a cross-build (1.52 KB, patch)
2002-09-26 20:37 UTC, Guy Streeter
no flags Details | Diff
xtpcall support for ppc (13.01 KB, patch)
2002-09-26 20:38 UTC, Guy Streeter
no flags Details | Diff

Description Guy Streeter 2002-09-26 20:35:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
mozilla needs an xptcall patch to build for ppc, and other changes to build for
ppc on a ppc64 system

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.on a ppc64 system, rpmbuild --target=ppc mozilla
2.
3.
	

Actual Results:  build errors

Expected Results:  sucessful build

Additional info:

I will attach patches.

Comment 1 Guy Streeter 2002-09-26 20:36:16 UTC
Created attachment 77364 [details]
spec file changes

Comment 2 Guy Streeter 2002-09-26 20:37:30 UTC
Created attachment 77365 [details]
keep configure from trying to do a cross-build

Comment 3 Guy Streeter 2002-09-26 20:38:15 UTC
Created attachment 77366 [details]
xtpcall support for ppc

Comment 4 Christopher Blizzard 2002-09-27 17:12:35 UTC
Are you sure that the asm changes will work with all the compilers that we
support?  If so, we need to get that in upstream.

Comment 5 Guy Streeter 2002-09-27 17:36:26 UTC
I got the xptcall patch from mozilla bugzilla. As I understand it, it has been
accepted.
http://bugzilla.mozilla.org/show_bug.cgi?id=142594


Comment 6 Guy Streeter 2005-03-30 20:56:00 UTC
This has long since been fixed


Note You need to log in before you can comment on or make changes to this bug.