Bug 745798 - 'groups' does not report group I am a member of
'groups' does not report group I am a member of
Status: CLOSED DUPLICATE of bug 745675
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-13 09:14 EDT by Ales Kozumplik
Modified: 2014-09-30 19:40 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-13 10:22:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ales Kozumplik 2011-10-13 09:14:03 EDT
Description of problem:
This is with the latest F16 beta, fully updated.

Steps to Reproduce:
1. as root: usermod -a -G wheel akozumpl
2. logout, login again as akozumpl
3. $ groups
  
Actual results:
akozumpl

Expected results:
akozumpl wheel

Additional info:
I did the 'usermod' step yesterday before doing 'yum update'. It was after 'yum update' when 'groups' stopped working correctly (I can still see my name with 'wheel' in /etc/groups).
Comment 1 Ondrej Vasik 2011-10-13 09:23:25 EDT
I don't think it has anything to do with groups command - groups (and id -Gn) is just using getgroups(2) from glibc.
So it might be issue with glibc or shadow-utils - let's try shadow-utils first. Peter, feel free to reassign it if you thing that the issue is on different place.
Comment 2 Fabian Deutsch 2011-10-13 10:22:50 EDT

*** This bug has been marked as a duplicate of bug 745675 ***

Note You need to log in before you can comment on or make changes to this bug.