This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 74586 - Boot after install hangs after IDE loads
Boot after install hangs after IDE loads
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-26 17:54 EDT by Aaron Peterson
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-04 11:30:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aaron Peterson 2002-09-26 17:54:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623
Debian/1.0.0-0.woody.1

Description of problem:
After installing RedHat Advanced Server 2.1 on a VA Linux 2240 with the L440GX
(lancewood) motherboard, the system hangs after IDE.  This is not the symptom
from scsi resets (with apic fix), as we are well aware of this problem, and know
how to work around it.  

We have tried the UP, SMP and enterprise kernel all with the same results.  The
system loads just fine, and then after reboot hangs after it loads the IDE foo
in the kernel.  A Multiple Processor box works just fine, but a box with just
one processor will exhibit the problems described.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Load RHAS2.1 on L440GX board with one processor.
2.  Boot System with any of the AS kernels from CDs.
3.  
	

Actual Results:  Hung...

Expected Results:  System should boot...

Additional info:

This is where it hung:

RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz PCI bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 91
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x1000-0x1007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x1008-0x100f, BIOS settings: hdc:pio, hdd:pio
Comment 1 Aaron Peterson 2003-01-29 17:18:29 EST
I guess after four months this is just being completely ignored??

--
sithender
Comment 2 Dan Norris 2003-09-22 15:45:18 EDT
I had experienced a very similar problem on two different systems.  One is a 
Dell 1650 (single CPU) and the other is a (slightly older) Dell 2400 (single 
CPU).  On both systems, the e.3 UP kernel booted fine, but the e.3 enterprise 
kernel refuses to boot (hangs just after the ide: Assuming 33MHz PCI bus 
speed...).  On the 1650, I tried booting e.24 enterprise and it had the same 
problem, but e.24 (up) boots fine.  On both systems, however, the e.27 kernels 
(up, smp, and enterprise) all boot fine.  Must have been something fixed in 
between e.24 and e.27 that did the trick for my two systems.

Note You need to log in before you can comment on or make changes to this bug.