Bug 74593 - DPMS is not working on Radeon QD
DPMS is not working on Radeon QD
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-27 03:53 EDT by Adam Pribyl
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-17 16:24:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Radeon QD log (69.25 KB, text/plain)
2002-09-30 03:45 EDT, Adam Pribyl
no flags Details
Radeon QD config (4.22 KB, text/plain)
2002-09-30 03:48 EDT, Adam Pribyl
no flags Details
Radeon QD lspci (2.33 KB, text/plain)
2002-09-30 03:51 EDT, Adam Pribyl
no flags Details
XF86Config Radeon 7500 (4.21 KB, text/plain)
2002-10-19 13:29 EDT, Adam Pribyl
no flags Details
Radeon 7500 log (51.24 KB, text/plain)
2002-10-19 13:31 EDT, Adam Pribyl
no flags Details
Radeon 7500 lspci (2.33 KB, text/plain)
2002-10-19 13:33 EDT, Adam Pribyl
no flags Details

  None (edit)
Description Adam Pribyl 2002-09-27 03:53:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607

Description of problem:
DPMS can be enabled by inserting Option "DPMS" into XF86Config-4 or disabled by
removeing this option, still it works the way that monitor switches off and on
again repeatedly while screen is still black.
When setting DPMS ServerFlags, only time and slightly behaviour is changing.
Never it works as it should according flags.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.need Radeon QD version
2.start XFree 4.2.0-8
3.wait until monitor tries to switch off
	

Actual Results:  monitor is flashing while still switching off and on

Expected Results:  monitor switches off and stays like this till next user event

Additional info:

For sure it is not caused by monitor. DPMS works on same machine with Radeon
7500. My Radeon QD is AIW type. In XFree86.0.log there is mentioned:
(II) Loading extension DPMS
(II) RADEON(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
Nothing more when DPMS is diabled, when enabled there is one more message about
DPMS enabling.
Comment 1 Mike A. Harris 2002-09-29 13:19:26 EDT
I've got 4 Radeon QD cards here, including the one you mention.  I'll
test each of them with DPMS and provide my results here.

In the mean time, please attach the config file and log file from the
working DPMS on the 7500, and the config and log file for the non-working
one also.

In addition, please attach the output of:  lspci -vn
Comment 2 Adam Pribyl 2002-09-30 03:42:52 EDT
In attachment there is config, log and lspci of non working Radeon AIW QD.
There is one more man available with same trouble. Here is his mail in XFree org
mailinglist: http://www.xfree86.org/pipermail/xpert/2002-May/017499.html
I do not have Radeon 7500 available at this time, next week I'll have it again
so I can test it.
Comment 3 Adam Pribyl 2002-09-30 03:45:04 EDT
Created attachment 77664 [details]
Radeon QD log
Comment 4 Adam Pribyl 2002-09-30 03:48:04 EDT
Created attachment 77665 [details]
Radeon QD config
Comment 5 Adam Pribyl 2002-09-30 03:51:04 EDT
Created attachment 77666 [details]
Radeon QD lspci
Comment 6 Adam Pribyl 2002-09-30 03:53:32 EDT
Please note that at this time I have in X gatos ati.2 driver, but behaviou od
DPMS is the same for ati driver provided by XFree.
Comment 7 Adam Pribyl 2002-10-19 13:29:54 EDT
Created attachment 81125 [details]
XF86Config Radeon 7500
Comment 8 Adam Pribyl 2002-10-19 13:31:24 EDT
Created attachment 81126 [details]
Radeon 7500 log
Comment 9 Adam Pribyl 2002-10-19 13:33:18 EDT
Created attachment 81127 [details]
Radeon 7500 lspci
Comment 10 Adam Pribyl 2002-10-19 13:43:07 EDT
..still gatos ati.2 driver. Now with Radeon 7500, DPMS is working as it should.
At least DPMS is activated according to flags.

I have one new info: in KDE it seems that at least when DPMS is disabled monitor
goes never to blank and screen saver is activated instead. But according to my
knowledge, KDE has (had?) own mechanism to handle DPMS.

Comment 11 Mike A. Harris 2002-12-17 16:24:08 EST
DPMS works flawlessly for me on Radeon QD.  To confirm, I have enabled
DPMS in my XF86Config-4 on RHL 7.3, having set the timeouts to 1, 2, and
3 minutes respectively.  I then type simply "X" to start the X server up
without any desktop, so that only the X server itself is running, and no
KDE/GNOME/whatever applications are interfering or overriding the X
server's DPMS settings.

As expected, all of the DPMS states work properly.  You should be able
to easily reproduce this test.  If you do, but DPMS still doesn't work
in GNOME and/or KDE, then it is either a GNOME/KDE misconfiguration or
a GNOME/KDE issue and not an XFree86 issue.

Note also that Red Hat does not support GATOS drivers installed on the
system.
Comment 12 Adam Pribyl 2002-12-18 05:15:00 EST
Hm. I did exacly the same in past before reporting this bug (otherwise I did not
fill the bug in) - no KDE or GNOME, only pure Xserver. Also without gatos driver
with original one from RH. Maybe it is caused by different occasions - monitor
type or reduction. I sometimes get message, during monitor tries to switch off -
Invalid Scan Frequency - that is monitor message, not X message. But in console
DPMS is working properly..
Comment 13 Adam Pribyl 2002-12-18 08:43:30 EST
Well, I did not the same. I used to start X by command "xinit" at that is the
difference. I do not know what app from xinit is disturbing DPMS yet, but this
is not definitely caused by Xserver.

But still here remains one thing I do not understand - DPMS is used even if
Option "dpms" is NOT specified in config file. Can you confirm this?

It looks like this in my config:

...
Section "ServerFlags"
        Option          "BlankTime" "1"
        Option          "StandbyTime" "2"
        Option          "SuspendTime" "3"
        Option          "OffTime" "4"
EndSection

Section "Monitor"
        Identifier "CM772"
        VendorName "HTC"
        ModelName  "CM772"
        HorizSync 31 - 115
        VertRefresh 50 - 160
#       Option "dpms"
...

Comment 14 Mike A. Harris 2002-12-18 13:45:14 EST
Bugzilla is not a technical support forum, so if you have further
technical support questions, you may wish to join and end user
tech support discussion list for help configuring DPMS properly
such as:  xpert@xfree86.org

As I said above, I am unable to reproduce this problem on any Radeon
hardware I have here.  DPMS works on all releases of XFree86 that I
have tried, and I have never had problems with DPMS on Radeon.  I
specifically tested your card using the info you provided, and was
unable to reproduce a problem.  DPMS configuration is trivial really,
and if there are DPMS related problems in the source code of X, they
would be extremely reproduceable.

Please take all further discussion to the mailing list refered to
above.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.