Bug 745946 - DNS privilege available without any DNS permissions
Summary: DNS privilege available without any DNS permissions
Keywords:
Status: CLOSED DUPLICATE of bug 742327
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.1
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Rob Crittenden
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-13 14:03 UTC by Namita Soman
Modified: 2011-10-13 14:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-13 14:33:12 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Namita Soman 2011-10-13 14:03:45 UTC
Description of problem:
Privilege for DNS Administrators and DNS Servers are available in install, but there are no DNS permissions installed.

# ipa privilege-show "DNS Administrators" --all
  dn: cn=dns administrators,cn=privileges,cn=pbac,dc=testrelm
  Privilege name: DNS Administrators
  Description: DNS Administrators
  objectclass: top, groupofnames, nestedgroup


# ipa permission-find DNS
---------------------
0 permissions matched
---------------------


Version-Release number of selected component (if applicable):
ipa-server-2.1.2-2.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.ipa privilege-show "DNS Administrators" --all
2.ipa permission-find DNS

  
Actual results:
No permissions available to administer DNS

Expected results:
permissions should be available to administer DNS.
Privilege for DNS should include these permissions

Additional info:

Comment 2 Martin Kosek 2011-10-13 14:33:12 UTC

*** This bug has been marked as a duplicate of bug 742327 ***


Note You need to log in before you can comment on or make changes to this bug.