Bug 745968 - [ipa webui] RFE: Add a link is DNS Record for a host to navigate to its reverse zone
Summary: [ipa webui] RFE: Add a link is DNS Record for a host to navigate to its rever...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rob Crittenden
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: 756082
TreeView+ depends on / blocked
 
Reported: 2011-10-13 14:28 UTC by Namita Soman
Modified: 2012-06-20 13:15 UTC (History)
3 users (show)

Fixed In Version: ipa-2.2.0-3.el6
Doc Type: Enhancement
Doc Text:
Cause: In Web UI in DNS page isn't a method how to navigate from A or AAAA record to related PTR record. Consequence: User can't perform following navigation chain: Host->DNS A record->DNS PTR record. Change: Proper link was added to to DNS page for A and AAAA records. Result: User can navigate from A, AAAA DNS records to related PTR records if they exist.
Clone Of:
Environment:
Last Closed: 2012-06-20 13:15:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0819 normal SHIPPED_LIVE ipa bug fix and enhancement update 2012-06-19 20:34:17 UTC

Description Namita Soman 2011-10-13 14:28:25 UTC
Description of problem:
Navigation is available from a Host record to its DNS record, but cannot navigate to its PTR record, from here. 
Can add a PTR record here, but RFE to be able to navigate to its existing PTR record easily from here


Version-Release number of selected component (if applicable):
ipa-server-2.1.2-2.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Click on a host to edit it
2. Click on 'Host anme" to go to its DNS record

  
Actual results:
No link here to go to its reverse zone

Expected results:
Be able to navigate to its reverse zone

Additional info:

Comment 2 Dmitri Pal 2011-10-13 16:15:30 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/1975

Comment 3 Petr Vobornik 2012-02-15 08:57:01 UTC
Fixed upstream

master: 8ad295a554a63f6b9101b080554fffa7f6f25c0a

ipa-2-2: 578669daa42b1b34d5e76462aa42dea89d1a2f32

Comment 5 Jenny Severance 2012-04-18 15:49:20 UTC
verified:
FQDN on Host details page is now a link that brings you to the host's DNS records and the short hostname on the DNS record page brings you to the Host's details page

version:
ipa-server-2.1.3-9.el6.x86_64

Comment 6 Petr Vobornik 2012-04-24 13:34:28 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: In Web UI in DNS page isn't a method how to navigate from A or AAAA record to related PTR record.
Consequence: User can't perform following navigation chain: Host->DNS A record->DNS PTR record.
Change: Proper link was added to to DNS page for A and AAAA records.
Result: User can navigate from A, AAAA DNS records to related PTR records if they exist.

Comment 8 errata-xmlrpc 2012-06-20 13:15:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html


Note You need to log in before you can comment on or make changes to this bug.