Bug 74597 - startup script never flushes the queue
Summary: startup script never flushes the queue
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-27 13:35 UTC by Bastien Nocera
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-27 13:36:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
corrected sendmail script (2.53 KB, text/plain)
2002-09-27 13:36 UTC, Bastien Nocera
no flags Details

Description Bastien Nocera 2002-09-27 13:35:15 UTC
From one of our customers:

I have found that the startup script for sendmail is faulty. It doesnt
startup the sm-client correctly.

The sequence of events should be:
a) startup sendmail SMTP daemon
b) startup sendmail sm-client mail queue daemon

With the version provided in the RPM only the SMTP daemon is started and the
queue is never processed because using the daemon function it always finds
the SMTP sendmail daemon running already and therefore never starts the
sendmail sm-client daemon.

I have updated the /etc/rc.d/init.d/sendmail script (see attachment) to
correctly start the sm-client daemon as well.

Comment 1 Bastien Nocera 2002-09-27 13:36:10 UTC
Created attachment 77464 [details]
corrected sendmail script

Comment 2 Florian La Roche 2002-12-02 21:36:49 UTC
This should be working fine with the current version, otherwise  please open
up a new bugreport.

Thanks,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.