Bug 74600 - DMA on cdrom not disabled
Summary: DMA on cdrom not disabled
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-27 14:50 UTC by Daniel Roche
Modified: 2014-03-17 02:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-27 14:50:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Roche 2002-09-27 14:50:07 UTC
Description of Problem:

On a computer with only one ide cdrom device ( scsi disks and 1 ide cdrom )
the rc.sysinit script failed to turn off DMA on cdrom.

I have met the problem on a compaq proliant 3xx server, because the kernel
crashes if you try to use the cdrom with the dma enabled !

Version-Release number of selected component (if applicable):

initscripts 6.67

How Reproducible:

each time 

Steps to Reproduce:
1. 
just boot a system with only one ide cdrom ( scsi disks )

Actual Results:

the DMA is ON for the cdrom

Expected Results:

it should be OFF

Additional Information:

the problem comes from the :
grep -v ide-disk /proc/ide/*/*/driver 2>/dev/null | awk -F / '{ print $5 }'`

if you have only one ide device, the grep does not add the path of the file
before the matching string, and thus the awk find nothing !

using grep -lv ide-disk..... will solve the problem.

Best Regards

Comment 1 Bill Nottingham 2002-09-27 15:59:40 UTC
Yeah, that code is broken. It's removed in current releases due to it being the
wrong way to do things.


Note You need to log in before you can comment on or make changes to this bug.