Bug 746002 - User added to /etc/group doesn't belong to this group
User added to /etc/group doesn't belong to this group
Status: CLOSED DUPLICATE of bug 745675
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-13 11:33 EDT by Artur Szymczak
Modified: 2011-10-13 16:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-13 16:01:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artur Szymczak 2011-10-13 11:33:52 EDT
Description of problem:

I added my user to group 'wheel'. But it seems that it doesn't belong to this group.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. usermod -a -G wheel artur
2. id artur
3. grep artur /etc/group
  
Actual results:
# usermod -a -G wheel artur
# id artur
uid=1000(artur) gid=1000(artur) groups=1000(artur)
# grep artur /etc/group
wheel:x:10:artur
artur:x:1000:


Expected results:
# usermod -a -G wheel artur
# id artur
uid=1000(artur) gid=1000(artur) groups=1000(artur),10(wheel)
# grep artur /etc/group
wheel:x:10:artur
artur:x:1000:


Additional info:
Comment 1 Ondrej Vasik 2011-10-13 16:01:29 EDT
Thanks for report. Command id/groups just uses getgroup(2) from glibc. Btw. your steps to reproduce are incomplete - please read info documentation for id/group - "Primary and supplementary groups for a process are normally inherited
from its parent and are usually unchanged since login.  This means that
if you change the group database after logging in, `groups' will not
reflect your changes within your existing login session." - so before the logout/login, that's perfectly ok and documented behaviour.

Anyway, it seems that glibc is now a bit buggy, there are more such reports... closing as duplicate of glibc bug.

*** This bug has been marked as a duplicate of bug 745675 ***

Note You need to log in before you can comment on or make changes to this bug.