Bug 74603 - USB keyboard dead in BOOT kernel.
USB keyboard dead in BOOT kernel.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-27 11:50 EDT by Robert Hentosh
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-27 18:41:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output for -BOOT kernel / USB keyboard fails (11.10 KB, text/plain)
2002-09-27 17:01 EDT, Robert Hentosh
no flags Details
dmesg output from -UP kernel / keyboard works. (8.12 KB, text/plain)
2002-09-27 17:53 EDT, Robert Hentosh
no flags Details

  None (edit)
Description Robert Hentosh 2002-09-27 11:50:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; H010818)

Description of problem:
On a workstation using the VIA VT6202 USB controller, the USB attached keyboard 
is dead when running BOOT controller.  The keyboard works well when the system 
is running the UP or SMP kernel.  This prevents an install on this system when 
only a USB keyboard is conected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot system from CD1.
2. USB keyboard will not respond after the boot: prompt during the first 
install screen to choose language.

	

Actual Results:  Keyboard is non-responsive during the install or when running 
the BOOT kernel.

Expected Results:  Expect USB keyboard to work during install as it does when 
system is finally installed.

Additional info:
Comment 1 John A. Hull 2002-09-27 15:45:14 EDT
This issue was found in Milan.
Comment 2 Pete Zaitcev 2002-09-27 15:50:22 EDT
Please tell me if the problem can be reproduced by booting
installed userland with BOOT kernel. The -BOOT kernel RPM
can be installed on a plain system and added to /boot/grub/grub.conf
just any other kernel.

If the problem is reproduced, please use a network login to
capture dmesg by running "dmesg >/tmp/dmesg.out", then attach
the dmesg.out file to the bug. PLEASE DO NOT DROP dmesg.out
INTO THE COMMENTS BOX.
Comment 3 Robert Hentosh 2002-09-27 16:42:13 EDT
Yes, it does. If I install the -BOOT kernel rpm and select it from grub I lose 
USB keyboard support. I will get a copy of dmesg and attach it.
Comment 4 Robert Hentosh 2002-09-27 17:01:21 EDT
Created attachment 77544 [details]
dmesg output for -BOOT kernel / USB keyboard fails
Comment 5 Pete Zaitcev 2002-09-27 17:22:12 EDT
Thanks for the dmesg. It indicates a dead interrupt line problem
(it normally causes -110 errors). Perhaps -BOOT does parsing
of some tables wrong, or has components missing.

I would like to have 3 things done here.

1. Try to boot with "noapic", to see if the workaround works.
If it does, it will carry us over for now.

2. Get output of "cat /proc/interrupts" with the same technique
as dmesg.out, to confirm that it's actually interrupt routing problem.

3. Collect dmesg and /proc/interrupts on a working SMP kernel,
so that we can compare those and see what is different.

That would be helpful.
Comment 6 Robert Hentosh 2002-09-27 17:51:54 EDT
I should mention that the keyboard works with the UP kernel. (So that is already
noapic).  I will include the dmesg from the UP kernel.
Comment 7 Robert Hentosh 2002-09-27 17:53:00 EDT
Created attachment 77545 [details]
dmesg output from -UP kernel / keyboard works.
Comment 8 Robert Hentosh 2002-09-27 18:10:46 EDT
Booting the -BOOT kernel with noapic WORKS!  That is a shocker. I thought the
BOOT kernel was noapic by default.
Comment 9 Pete Zaitcev 2002-09-27 18:41:29 EDT
Yes, the BIOS is broken on the box. Windows cuts over to ACPI,
so BIOS writers let normal tables to bitrot all across the board.

If would be helpful if you downloaded an RPM from my web page and
ran the program in it, called "mptable". Please add "-pirq" flag too.
URL:
 http://people.redhat.com/zaitcev/linux/mptable-2.0.15a-1.i386.rpm
The result can be used to discuss the problem with BIOS people.

The working SMP kernel dmesg that you mentioned in the report
won't hurt.
Comment 10 Robert Hentosh 2002-09-30 10:08:23 EDT
Thanks very much for your prompt attention.  I didn't realize that the -BOOT
kernel also used the mptables. The problem makes sense, now.

Note You need to log in before you can comment on or make changes to this bug.