This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 74604 - evolution crashes starting -- Configuration Database not found
evolution crashes starting -- Configuration Database not found
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: ORBit (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Havoc Pennington
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-27 12:01 EDT by Chris Ricker
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 23:01:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace of crash (864.53 KB, text/plain)
2002-09-30 15:43 EDT, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2002-09-27 12:01:12 EDT
This is with RHL 8.0

I did an everything install, and started using evolution.


When I logged in this morning, evolution fails to start.  It reports:

"Cannot initialize the Ximian Evolution shell:  Configuration Database not found"

in a dialog box, and


evolution-shell-WARNING **: Cannot access Bonobo/ConfigDatabase on wombat:
(IDL:OAF/GeneralError:1.0)

in the xterm I'm launching it from....

This appears to be a different issue than Bug #68412, since I've not changed any
packages from a stock RHL 8 everything install (other than adding acroread)
Comment 1 Jeremy Katz 2002-09-27 15:49:02 EDT
What happens if you just try to run wombat by hand from a terminal?
Comment 2 Chris Ricker 2002-09-27 16:02:44 EDT
It's probably too late now.  I went about systematically whacking config files
until it got fixed:

* first removed ~/evolution (didn't fix)
* then removed ~/.* (anything vaguely gnome / gtk+ / etc. related; didn't fix)
* then removed /tmp/* && /tmp/.* (after init 1; that fixed it)

Now things are working again.  It's since died on me a second time, but this
time evkill was enough to get it going....

Just for my future reference, what *should* I have done when I got that error
message?
Comment 3 Jeremy Katz 2002-09-27 16:08:07 EDT
Running wombat by hand probably would have given a more verbose error message. 
If what you did fixed it, did you by chance have had like a /tmp/orbit-username
that wasn't owned by your user?
Comment 4 Chris Ricker 2002-09-27 16:16:55 EDT
That's quite possible.  I removed everything in /tmp as root b/c the normal user
didn't have permission to delete the kde-* and orbit-* directories there....  I
didn't note the permissions on the directories explicitly, though.

(you'll probably have to close this as WORKSFORME or something similar, given
the lack of info on my end ;-)
Comment 5 Jeremy Katz 2002-09-27 16:55:03 EDT
Guessing it has to do with that then
Comment 6 Chris Ricker 2002-09-27 16:59:42 EDT
Okay, it's broken again.  This time I promise not to fix it so that you can
diagnose it ;-)

When I start evolution, I get

chilton@dartagnan chilton]$ evolution

evolution-shell-WARNING **: Cannot access Bonobo/ConfigDatabase on wombat:
(IDL:OAF/GeneralError:1.0)
[chilton@dartagnan chilton]$ 

So then I try starting wombat:

[chilton@dartagnan chilton]$ wombat
wombat-Message: Starting wombat


And that seems to work fine.  It's running now.

But evolution still won't start:

[1]+  Stopped                 wombat
[chilton@dartagnan chilton]$ bg
[1]+ wombat &
[chilton@dartagnan chilton]$ evolution

evolution-shell-WARNING **: Cannot access Bonobo/ConfigDatabase on wombat:
(IDL:Bonobo/Moniker/InterfaceNotFound:1.0)
[chilton@dartagnan chilton]$
Comment 7 Chris Ricker 2002-09-27 17:00:31 EDT
/tmp looks fine:

[chilton@dartagnan tmp]$ ls -l
total 5776
srw-------    1 chilton  chilton         0 Sep 27 13:19 gaim_chilton.1713
-rw-------    1 chilton  chilton       991 Sep 27 13:19 gaimNxhQOZ
-rw-rw-r--    1 chilton  chilton      9728 Nov  3  1999 GLFb3bb.tmp
-rw-rw-r--    1 chilton  chilton     53248 Aug  7 22:24 installutilities.dll
drwx------    2 chilton  chilton      4096 Sep 27 13:37 kde-chilton
drwx------    2 chilton  chilton      4096 Sep 27 13:38 ksocket-chilton
drwx------    2 chilton  chilton      4096 Sep 27 14:59 orbit-chilton
drwx------    2 chilton  chilton      4096 Sep 27 14:55 ssh-XXzVvGCW
-rw-------    1 chilton  chilton   5804688 Sep 27 13:36 stamps.exe
drwxrwxr-x    2 chilton  chilton      4096 Sep 27 13:52 tmp
[chilton@dartagnan tmp]$

Comment 8 Chris Ricker 2002-09-30 15:43:17 EDT
Created attachment 77744 [details]
strace of crash
Comment 9 Chris Ricker 2002-09-30 15:44:10 EDT
attached a strace -f of it failing to start
Comment 10 Jeremy Katz 2002-10-11 12:05:51 EDT
And then if you move /tmp/orbit-chilton out of the way, it starts working again?
Comment 11 Chris Ricker 2002-10-11 12:20:58 EDT
Yes
Comment 12 Jeremy Katz 2002-10-11 17:35:05 EDT
Havoc -- do you have any ideas here?  It looks like something strange with ORBit
to me
Comment 13 Havoc Pennington 2002-10-11 17:44:07 EDT
I thought the "configuration database not found" stuff was in the evolution FAQ?
Comment 14 Jeremy Katz 2002-10-11 17:48:59 EDT
The FAQ handles cases where the oaf files don't get installed and where
mozilla-nspr isn't installed for some reason.  Since moving the orbit dir out of
the way fixes it in this case, neither of those seem to be the case.

Chris -- do you have any problems with other GNOME 1.x apps that use ORBit like
gnumeric when this happens?
Comment 15 Chris Ricker 2002-10-11 18:34:07 EDT
I haven't noticed other problems, but I might have missed it (can't think of any
gnome 1.4 apps used regularly besides evolution).  When it breaks again, I'll
try out gnumeric.
Comment 16 Chris Ricker 2002-11-12 19:11:03 EST
When it breaks, gnumeric is also broken, with a missing configuration database
error....

The initial problem (evolution not starting) is fixed by evolution-1.2.  I put
the rpms

[root@dartagnan bins]# rpm -qa | grep ximian
libgal21-0.21-1.ximian.1
gtkhtml-devel-1.0.4-6.ximian.1
bonobo-conf-0.16-1.ximian.1
libbonobo-conf0-0.16-1.ximian.1
libgtkhtml1.1-3-1.1.6-1.ximian.1
soup-0.7.9-1.ximian.1
gal-0.21-1.ximian.1
gtkhtml1.1-1.1.6-1.ximian.1
evolution-1.2.0-1.ximian.1
gal-devel-0.21-1.ximian.1
libgtkhtml20-1.0.4-6.ximian.1
[root@dartagnan bins]# 

on the system and it at least starts and runs now....
Comment 17 Chris Ricker 2002-11-13 11:16:53 EST
Hmm.  This morning evolution 1.2 was broken (standard db error) but gnumeric
still worked....

A reboot fixed evolution, at least for the time being.
Comment 18 Havoc Pennington 2003-01-12 17:41:47 EST
I don't really have a clue here, suggest we file on gnome.org and see 
if they're familiar with it.
Comment 19 Havoc Pennington 2003-01-12 23:01:29 EST
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103323

Note You need to log in before you can comment on or make changes to this bug.