Bug 746110 - [abrt] tumbler-0.1.22-3.fc16: Process /usr/lib/tumbler-1/tumblerd was killed by signal 6 (SIGABRT)
[abrt] tumbler-0.1.22-3.fc16: Process /usr/lib/tumbler-1/tumblerd was killed ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tumbler (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:fba2fce6f7784b902f37667b33d...
: Reopened
Depends On:
Blocks: F16Blocker-xfce
  Show dependency treegraph
 
Reported: 2011-10-13 18:07 EDT by Thomas Meyer
Modified: 2011-10-24 23:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: tumbler-0.1.22-4.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 23:25:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: maps (24.63 KB, text/plain)
2011-10-13 18:07 EDT, Thomas Meyer
no flags Details
File: backtrace (48.38 KB, text/plain)
2011-10-13 18:07 EDT, Thomas Meyer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 8040 None None None Never

  None (edit)
Description Thomas Meyer 2011-10-13 18:07:05 EDT
libreport version: 2.0.6
abrt_version:   2.0.4.981
backtrace_rating: 4
cmdline:        /usr/lib/tumbler-1/tumblerd
comment:        I don't know. It seems to have crashed in the background or so.
executable:     /usr/lib/tumbler-1/tumblerd
kernel:         3.0.6
reason:         Process /usr/lib/tumbler-1/tumblerd was killed by signal 6 (SIGABRT)
time:           Thu Oct 13 23:51:26 2011
uid:            500
username:       thomas
var_log_messages: Oct 13 23:51:27 localhost abrt[9878]: saved core dump of pid 9815 (/usr/lib/tumbler-1/tumblerd) to /var/spool/abrt/ccpp-2011-10-13-23:51:26-9815 (76156928 bytes)

backtrace:      Text file, 49542 bytes
maps:           Text file, 25222 bytes

build_ids:
:b372c8086ecb8055a9d750e6868a85f804b9ef38
:c5693dd75d7d12a254ab9ed79efed0458d957d80
:e86c829bf8553d6b593dbd8c4df0957268dc8328
:e4eefa7b8543965da58d320402d093ef76cdb034
:2783c7cba310a0ccae65ef8d8d8434d8ac64dfed
:f7ca6d83c301e6041c1b8db9bf6e48c610f4c88d
:ba1cf8e15137ea5b6bbfac8dbcfdeb22026731d6
:07b08fc8a58c52b18fe7e29de09b714b86dfce1f
:cbcceeae2feae8153a8f183ff1c33f2a5462ba65
:1f60ce3a43a5e6db2df2252da25ac0aa9f90b6b9
:cd4cef7d6897e8ab9d3a13b75735342787c7590b
:f4030ac5e399b27aa6f713658231a323bfb956d5
:b2d5c5f02b6e6eb34dc593699c0b0bf516280159
:647951954dab9eadcf521b97c5f9d7566b1e79c8
:fda3e6da8c0459b7b76437dadfc89bfa21180c63
:9b74e05fa75cf73df1da0c05a7b1528f0ec8a0f0
:fc10592c8f143850c6361c650d4bb195d80d1a35
:42859023e4ec83a16446984b1e0c7510a38731c4
:4a52e927b46209d7398942793d15f115e756a1b6
:aa9a4df5fa16320332ea125a458d7c569194d323
:0d707a69ae806116306bdc294c8d489dd8d70edb
:dcedf9d0146a0ce09b31264f5ace5497cf56adff
:39015758b558b962e6641f609b8eb49e5d254329
:21fe8f95282cd4b0523fcf6eb6003066cb3e5beb
:1a334343e9150055e255cb8982b7e5cbbc201a77
:-
:d2c8780304a253c8162b3ac1313c895028d8c63a
:cf31c261ba84587d5743c8689e847dc6dbc2df2a
:20e5cf88f9b4f0db7c0ac2c5d0253168db84b750
:7365814f489e7de923271dd2709f6b17e0065092
:5e351f829c2f3e8cd9e1150f0da739bf10003bc2
:07688ab374c5618055eb3452daf9b16049ef0631
:f88be2cb4a239cfdee1e4011be830abb0d9ed763
:25135b10bfd0f1607642fb2a14771273e5046e26
:e1b86d70cbf35e8ce79a9e8f6a617c77390db0ed
:9ce295deebbab9a3bb1e2a3fa16e88d4ded9a9e1
:4bf0790095da2cd01a3e53032b03558908929633
:2954b58b084514ba70b0e71fc8bb2572013860f3
:e879c834a1fb6526b3a7f5917edde3112cccf1af
:aa00d88ccea615696e431f9da117f1652f1c72c3
:6ad77e91d5cc02288d676787c163373f4fefe8fa
:d55e1abef167768e36fb69f865f31a43ca4a9866
:15bab279752ad8e30f901abae77bcb1ed1f38977
:c44607ad52f9f0742390d7e8acb61b3c87fc9ba7
:3d801e1dbc89620e57b7fe67abeb5a1ff65ebd94
:23dcd27ef22035315a271ec828c8ac90fa58c6e9
:1a8743ef4f021331ce4d75afa665839a871618ec
:6cb89d7614a168bead5e99321b3cb1245877b4fa
:450542e307fe6e71c919583b9a04e67ce0808076
:f1bf4a69b2a1b3b4d82f13d86c40cd3f8e4b2814
:d227cdc05f915ec8c139ae16d289a953e79b6b65
:5fff334d8526c8bf89a5c7cf4a54c3663f456548
:798697a352bae4178953ba502fb04f33dd0ed987
:3559985788f3dd48ed3f09aec8faa42147c6d1d4
:adca4c604227da51f7a095c00f343e39dda76d54
:28c6e12b60481179563c5ab4f84d9f76e00d07a5
:322f325ea640b6e4c2a76c22801eef08e3f000c3
:bdbcb7ad0ae16806e9002af3c6d1ec65353108a0
:527caee5d59eb9dba4728508f9bf687922b57ecf
:a04c18281d2af00b0518696ff8509c7085c7e424
:7edfe33206e21278bc66d501f779a72c30dca032
:8403f33f0be1a3653acd05b560f87aa1363d02d7
:4ae55c9126e7316479c90318c0fa390dc5db470f
:4da0113526e0b678cd8ef023bd39b8a2f0e1d199
:59b5cd3ec713a9cb7976adf39d608e27137d0a20
:a630bc89c424e038dc4f8b0424557ae375cfdff9
:52ceee1d91415a6f9305bf5f9f0c7b2aa6213aaa
:d94f52f020f5a21d89ce70745a9bfb78cee38ba4
:e8d78ad829e121ba0319157524c5cc81ce46d4cf
:eef088193b4554c96911296f4bc994dde53f004a
:28b8cc9cda751c67558ec59cc16019154ebf56ae
:0880bc8df67cde42fafc2140a70ba94b08cbde4e
:38c4afdb1d64fe30f7ca5ce2ab37dcf9cff72261
:f5b2ca17e2d28029094b309e75a88d519c25cd29
:1590c95088a0e5c2c2e3286dbe095d706fb9e600
:456028c1f4637c57c9d1159e73c3481fd12ff9aa
:4b045111479e1ec97d0ef5668482bf808e8dadba
:55433495aa80cf9e1f994ea7e7ae278422ef1ede
:5338214d0c5471fb905d9f26949fadaf2024ae80

dso_list:
:/usr/lib/libpng12.so.0.46.0 libpng-2:1.2.46-1.fc16.i686 (Fedora Project) 1318070771
:/usr/lib/liblcms.so.1.0.19 lcms-libs-1.19-4.fc16.i686 (Fedora Project) 1318070837
:/usr/lib/gio/modules/libgvfsdbus.so gvfs-1.10.0-1.fc16.i686 (Fedora Project) 1318085009
:/usr/lib/gstreamer-0.10/libgstisomp4.so gstreamer-plugins-good-0.10.30-2.fc16.i686 (Fedora Project) 1318071968
:/usr/lib/gstreamer-0.10/libgstvolume.so gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-jpeg.so gdk-pixbuf2-2.24.0-1.fc16.i686 (Fedora Project) 1318070804
:/usr/lib/gconv/ISO8859-1.so glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/usr/lib/tumbler-1/plugins/tumbler-gst-thumbnailer.so tumbler-0.1.22-3.fc16.i686 (Fedora Project) 1318086091
:/usr/lib/libgstrtp-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/libgdk_pixbuf-2.0.so.0.2400.0 gdk-pixbuf2-2.24.0-1.fc16.i686 (Fedora Project) 1318070804
:/usr/share/locale/de/LC_MESSAGES/gdk-pixbuf.mo gdk-pixbuf2-2.24.0-1.fc16.i686 (Fedora Project) 1318070804
:/lib/librt-2.14.90.so glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/usr/share/locale/de/LC_MESSAGES/gstreamer-0.10.mo gstreamer-0.10.35-1.fc16.i686 (Fedora Project) 1318071184
:/lib/libgthread-2.0.so.0.3000.0 glib2-2.30.0-2.fc16.i686 (Fedora Project) 1318084442
:/usr/lib/locale/locale-archive glibc-common-2.14.90-11.i686 (Fedora Project) 1318486530
:/usr/share/locale/de/LC_MESSAGES/glib20.mo glib2-2.30.0-2.fc16.i686 (Fedora Project) 1318084442
:/usr/lib/libxml2.so.2.7.8 libxml2-2.7.8-6.fc16.i686 (Fedora Project) 1318070772
:/usr/lib/libgstcontroller-0.10.so.0.29.0 gstreamer-0.10.35-1.fc16.i686 (Fedora Project) 1318071184
:/usr/lib/libtumbler-1.so.0.0.0 tumbler-0.1.22-3.fc16.i686 (Fedora Project) 1318086091
:/usr/lib/tumbler-1/tumblerd tumbler-0.1.22-3.fc16.i686 (Fedora Project) 1318086091
:/lib/libpthread-2.14.90.so glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/usr/lib/liborc-test-0.4.so.0.16.0 orc-0.4.16-1.fc16.i686 (Fedora Project) 1318085359
:/usr/lib/libXrender.so.1.3.0 libXrender-0.9.6-2.fc15.i686 (Fedora Project) 1297691542
:/lib/libselinux.so.1 libselinux-2.1.5-5.1.fc16.i686 (Fedora Project) 1318084429
:/usr/lib/tumbler-1/plugins/cache/tumbler-xdg-cache.so tumbler-0.1.22-3.fc16.i686 (Fedora Project) 1318086091
:/usr/lib/libgstinterfaces-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/lib/libdl-2.14.90.so glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/usr/lib/gio/modules/libgioremote-volume-monitor.so gvfs-1.10.0-1.fc16.i686 (Fedora Project) 1318085009
:/usr/lib/liborc-0.4.so.0.16.0 orc-0.4.16-1.fc16.i686 (Fedora Project) 1318085359
:/usr/lib/tumbler-1/plugins/tumbler-font-thumbnailer.so tumbler-0.1.22-3.fc16.i686 (Fedora Project) 1318086091
:/lib/libc-2.14.90.so glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/usr/lib/libjpeg.so.62.0.0 libjpeg-turbo-1.1.1-1.fc16.i686 (Fedora Project) 1318070774
:/usr/lib/gstreamer-0.10/libgstdecodebin2.so gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/gstreamer-0.10/libgstffmpegcolorspace.so gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/lib/libm-2.14.90.so glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/usr/lib/gstreamer-0.10/libgstfluaacdec.so fluendo-codecs-complete-bundle-12-4.i386 (None) 1301686188
:/usr/lib/libxcb.so.1.1.0 libxcb-1.7-3.fc16.i686 (Fedora Project) 1318070801
:/usr/lib/gstreamer-0.10/libgstfluh264dec.so fluendo-codecs-complete-bundle-12-4.i386 (None) 1301686188
:/usr/lib/libpoppler-glib.so.8.2.0 poppler-glib-0.18.0-1.fc16.i686 (Fedora Project) 1318084530
:/usr/lib/gstreamer-0.10/libgstcoreelements.so gstreamer-0.10.35-1.fc16.i686 (Fedora Project) 1318071184
:/usr/lib/libpixman-1.so.0.22.2 pixman-0.22.2-1.fc16.i686 (Fedora Project) 1318070817
:/usr/lib/libfontconfig.so.1.4.4 fontconfig-2.8.0-4.fc16.i686 (Fedora Project) 1318071227
:/usr/lib/libXau.so.6.0.0 libXau-1.0.6-2.fc15.i686 (Fedora Project) 1297691537
:/usr/lib/gstreamer-0.10/libgstflumsb.so fluendo-codecs-complete-bundle-12-4.i386 (None) 1301686188
:/lib/libdbus-1.so.3.5.6 dbus-libs-1:1.4.10-3.fc16.i686 (Fedora Project) 1318070770
:/usr/lib/tumbler-1/plugins/tumbler-poppler-thumbnailer.so tumbler-0.1.22-3.fc16.i686 (Fedora Project) 1318086091
:/etc/localtime glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/lib/libutil-2.14.90.so glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/usr/lib/libgstvideo-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/lib/libz.so.1.2.5 zlib-1.2.5-4.fc16.i686 (Fedora Project) 1318070769
:/lib/libnss_files-2.14.90.so glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/usr/lib/libopenjpeg.so.3.1.4.0 openjpeg-libs-1.4-6.fc16.i686 (Fedora Project) 1318070891
:/usr/lib/libgvfscommon.so.0.0.0 gvfs-1.10.0-1.fc16.i686 (Fedora Project) 1318085009
:/lib/libgmodule-2.0.so.0.3000.0 glib2-2.30.0-2.fc16.i686 (Fedora Project) 1318084442
:/usr/lib/libgstpbutils-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/gstreamer-0.10/libgstvideoscale.so gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/libpoppler.so.18.0.0 poppler-0.18.0-1.fc16.i686 (Fedora Project) 1318084510
:/usr/share/locale/de/LC_MESSAGES/libc.mo glibc-common-2.14.90-11.i686 (Fedora Project) 1318486530
:/usr/lib/gstreamer-0.10/libgstplaybin.so gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/libgstreamer-0.10.so.0.29.0 gstreamer-0.10.35-1.fc16.i686 (Fedora Project) 1318071184
:/usr/lib/libfreetype.so.6.7.1 freetype-2.4.6-1.fc16.i686 (Fedora Project) 1318070768
:/usr/lib/libbluray.so.0.0.0 libbluray-0.2-0.5.20110710git51d7d60a96d06.fc16.i686 (Fedora Project) 1318070834
:/usr/lib/gstreamer-0.10/libgstaudioresample.so gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/libgstriff-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/gstreamer-0.10/libgsttypefindfunctions.so gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/gstreamer-0.10/libgstaudioconvert.so gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/tumbler-1/plugins/tumbler-jpeg-thumbnailer.so tumbler-0.1.22-3.fc16.i686 (Fedora Project) 1318086091
:/usr/lib/gconv/gconv-modules.cache glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/lib/libgobject-2.0.so.0.3000.0 glib2-2.30.0-2.fc16.i686 (Fedora Project) 1318084442
:/usr/lib/gconv/CP1252.so glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/usr/lib/libffi.so.5.0.10 libffi-3.0.10-1.fc16.i686 (Fedora Project) 1318084439
:/usr/lib/libstdc++.so.6.0.16 libstdc++-4.6.1-10.fc16.i686 (Fedora Project) 1318084431
:/lib/libgcc_s-4.6.1-20111002.so.1 libgcc-4.6.1-10.fc16.i686 (Fedora Project) 1318084394
:/usr/lib/libX11.so.6.3.0 libX11-1.4.3-1.fc16.i686 (Fedora Project) 1318070802
:/lib/libudev.so.0.12.0 libudev-173-3.fc16.i686 (Fedora Project) 1318070776
:/lib/libresolv-2.14.90.so glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/usr/share/locale/de/LC_MESSAGES/gst-plugins-base-0.10.mo gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/libgsttag-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/lib/libexpat.so.1.5.2 expat-2.0.1-11.fc15.i686 (Fedora Project) 1297691494
:/usr/lib/libgstbase-0.10.so.0.29.0 gstreamer-0.10.35-1.fc16.i686 (Fedora Project) 1318071184
:/usr/lib/libgstaudio-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-1.fc16.i686 (Fedora Project) 1318071330
:/usr/lib/tumbler-1/plugins/tumbler-pixbuf-thumbnailer.so tumbler-0.1.22-3.fc16.i686 (Fedora Project) 1318086091
:/usr/lib/libcairo.so.2.11000.2 cairo-1.10.2-4.fc16.i686 (Fedora Project) 1318071302
:/lib/ld-2.14.90.so glibc-2.14.90-11.i686 (Fedora Project) 1318486507
:/lib/libgio-2.0.so.0.3000.0 glib2-2.30.0-2.fc16.i686 (Fedora Project) 1318084442
:/lib/libglib-2.0.so.0.3000.0 glib2-2.30.0-2.fc16.i686 (Fedora Project) 1318084442
:/usr/lib/libdbus-glib-1.so.2.1.0 dbus-glib-0.92-2.fc15.i686 (Fedora Project) 1299881981

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-k8KeoWk6nR,guid=e73d7ab568b4dd39eaf7ba670000005b
:XDG_SESSION_COOKIE=b9dea6a2fc64da2bbb0fab7d00000052-1318361244.585396-1862014246
:XDG_RUNTIME_DIR=/run/user/thomas
:DISPLAY=:0
:DESKTOP_SESSION=xfce
:WINDOWPATH=7
:PATH=/usr/local/bin:/usr/bin:/bin
:GDMSESSION=xfce
:XDG_VTNR=7
:USERNAME=thomas
:XDG_SESSION_ID=2
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-k8KeoWk6nR,guid=e73d7ab568b4dd39eaf7ba670000005b
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-thomas-THVkOL/database
:USER=thomas
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1042
:SHLVL=1
:GDM_LANG=de_DE.utf8
:PWD=/home/thomas
:GNOME_KEYRING_CONTROL=/tmp/keyring-qSNzqy
:LANG=de_DE.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=thomas
:HOME=/home/thomas
Comment 1 Thomas Meyer 2011-10-13 18:07:09 EDT
Created attachment 528114 [details]
File: maps
Comment 2 Thomas Meyer 2011-10-13 18:07:11 EDT
Created attachment 528115 [details]
File: backtrace
Comment 3 Kevin Fenzi 2011-10-13 19:23:09 EDT
Looks like this is in the gstreamer plugins... 

tumbler-gst-thumbnailer:ERROR:gst-thumbnailer.c:121:is_interesting: assertion failed: (GDK_IS_PIXBUF (pixbuf))

Can you get it to happen again? Or was it one time?
Comment 4 Thomas Meyer 2011-10-15 07:51:52 EDT
Yes, it seems to happen everytime I open a directory in thunar containing some images or so. I currently have 9 unreported crashes in the abrt-gui. all looking like this bug.
Comment 5 Christoph Wickert 2011-10-15 09:36:39 EDT
Could it be that it is actually videos rather then images?
Comment 6 Thomas Meyer 2011-10-15 11:33:23 EDT
yes, on my Desktop are also video files. could also be these that crashes tracker.
Comment 7 Christoph Wickert 2011-10-16 04:45:03 EDT
Thanks for your response. I have forwarded your crash report to the developers at
https://bugzilla.xfce.org/show_bug.cgi?id=8040

From now on, further investigation of this bug should take place in the Xfce bug tracker. I will get back to you if I need more info and let you know once this bug is resolved in Fedora.
Comment 8 Fedora Update System 2011-10-16 06:58:05 EDT
tumbler-0.1.22-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/tumbler-0.1.22-4.fc16
Comment 9 Thomas Meyer 2011-10-16 08:51:59 EDT
Thanks Christoph. This fixes the crashes. thumbnails are actually created now.
Comment 10 Christoph Wickert 2011-10-22 16:23:36 EDT
I propose this as F16-accepted because the tumbler-0.1.22-4.fc16 update fixes two crashes (this one and bug 742733) and makes the thumbnail generation actually work. The update has been tested to fix the bugs.
Comment 11 Fedora Update System 2011-10-24 23:25:53 EDT
tumbler-0.1.22-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.