This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 746174 - Writer incorrectly stores numbering restart for odt documents
Writer incorrectly stores numbering restart for odt documents
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Stahl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-14 04:29 EDT by Pavel Alexeev
Modified: 2012-02-16 19:57 EST (History)
4 users (show)

See Also:
Fixed In Version: libreoffice-3.4.5.2-5.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-16 19:57:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Small problem reproduce (183.75 KB, application/vnd.oasis.opendocument.text)
2011-10-22 15:14 EDT, Pavel Alexeev
no flags Details

  None (edit)
Description Pavel Alexeev 2011-10-14 04:29:56 EDT
Description of problem:
I have one odt file when use many numeric list. It try it numerate through full document. I choose after each header from context menu "Begin numeration from start" (it may be some different, I use Russian language for work). Numeration changed as intended. Then I save document. Close writer. Open document again - and numeration change not stored.

Version-Release number of selected component (if applicable):
# rpm -qa 'libreoffice*'
libreoffice-langpack-ru-3.4.3.2-11.fc16.x86_64
libreoffice-presenter-screen-3.4.3.2-11.fc16.x86_64
libreoffice-calc-3.4.3.2-11.fc16.x86_64
libreoffice-kde-3.4.3.2-11.fc16.x86_64
libreoffice-graphicfilter-3.4.3.2-11.fc16.x86_64
libreoffice-writer-3.4.3.2-11.fc16.x86_64
libreoffice-core-3.4.3.2-11.fc16.x86_64
libreoffice-langpack-en-3.4.3.2-11.fc16.x86_64
libreoffice-ure-3.4.3.2-11.fc16.x86_64
libreoffice-pdfimport-3.4.3.2-11.fc16.x86_64
libreoffice-xsltfilter-3.4.3.2-11.fc16.x86_64
libreoffice-math-3.4.3.2-11.fc16.x86_64
libreoffice-draw-3.4.3.2-11.fc16.x86_64
libreoffice-impress-3.4.3.2-11.fc16.x86_64
libreoffice-opensymbol-fonts-3.4.3.2-11.fc16.noarch

How reproducible:
Always.
Comment 1 Caolan McNamara 2011-10-21 07:41:10 EDT
I don't understand the problem. Can you attach an example, or a step by step guide to reproduce.
Comment 2 Pavel Alexeev 2011-10-22 15:14:03 EDT
Created attachment 529632 [details]
Small problem reproduce

Ok, ok, it is my bad, sorry.

Full reproduce:
1. Open attached odt file. It is on Russian, but it shouldn't be problem.
2. Document contain 2 headers and two lists. All items enumerated continiusely 1-5.
3. Then press right mouse button on 3. numbered list item and choose "Restart Numbering". Numbering restarted and second list became 1-3 instead of 3-5.
4. Save and close Writer (may close and save by exit rexuest, there no differencies).
5. Open document again. All items enumerated as initially through document 1-5.
Comment 3 Caolan McNamara 2011-11-08 08:56:47 EST
Confirmed, caolanm->mstahl: can you find out if its a regression from an earlier version and try and track it down.
Comment 4 Michael Stahl 2012-01-23 14:20:14 EST
seems that under very special circumstances we don't export a list restart
if the paragraph has only the restart flag set but no start value set.

not a regression as far as i can tell; broken since OOo 3.0.1 at least.

fixed upstream master:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c82ed24c4e51492105b5d94e164ece3cf86d6d86
Comment 5 Pavel Alexeev 2012-01-23 15:28:36 EST
It is great news! Michael thank you very much!

When awaiting release and that fix landed to Fedora updates?
Comment 6 Michael Stahl 2012-02-03 05:45:36 EST
fixed in upstream libreoffice-3-5 branch as well:
31c8d797c40644e73f119b59c596432ffb6cf7ae

also added the patch to the Fedora f16 branch,
should be in the next update.
Comment 7 Fedora Update System 2012-02-07 11:43:46 EST
libreoffice-3.4.5.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.5.2-2.fc16
Comment 8 Fedora Update System 2012-02-07 21:27:37 EST
Package libreoffice-3.4.5.2-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.4.5.2-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1439/libreoffice-3.4.5.2-2.fc16
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-02-09 06:38:25 EST
libreoffice-3.4.5.2-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.5.2-5.fc16
Comment 10 Fedora Update System 2012-02-16 19:57:02 EST
libreoffice-3.4.5.2-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.