Bug 7462 - rp3-config core dumps
rp3-config core dumps
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-30 19:55 EST by nstn1291
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 18:26:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nstn1291 1999-11-30 19:55:44 EST
I just installed a new rpm for rp3.  It seems that it has fixed rp3 and
improved rp3-config.  However, rp3-config is still not healthy.  The
following trace from an X-window sessions may be helpful:

[leavitt@Learn leavitt]$
[leavitt@Learn leavitt]$ rp3-config

GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols
specified are supported and host-based authentication failed.
[leavitt@Learn leavitt]$
[leavitt@Learn leavitt]$ gdb rp3-config
GNU gdb 19991004
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
(gdb) r
Starting program: /usr/bin/rp3-config
(no debugging symbols found)...(no debugging symbols found)...

GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols
specified are supported and host-based authentication failed.
(no debugging symbols found)...(no debugging symbols found)...
Program exited normally.
(gdb) bt
No stack.
(gdb) quit
[leavitt@Learn leavitt]$

To get the above trace I ran rp3-config twice, first by itself, and the
second time using gdb.  Both times it prompted me for the root password.  I
am logged in as root, and I assume this is what it is supposed to do.  Both
times it then crashed, reporting a segmentation fault.  However, under gdb
it seems to have exited normally (after reporting a segmentation fault) so
there is no backtrace.
Comment 1 Michael K. Johnson 1999-12-01 15:59:59 EST
To get a stack trace of the configuration part, do
  su
  gdb /usr/sbin/rp3-config
  r
  bt
Otherwise, you are just debugging consolehelper, which doesn't
tell you much...  :-)

However, before you do any of that, try the test release at
ftp://people.redhat.com/johnsonm/rp3/rp3-1.0.2-1.i386.rpm
and see if it fixes the problem for you.
Comment 2 nstn1291 1999-12-01 21:53:59 EST
OK - I tried some more experiements.
I have installed the rpm rp3-1.0.2-1.i386.rpm.  It does not help.

In a Gnome X-Window I ran the following sequence:

[leavitt@Learn leavitt]$ su
Password:
[root@Learn leavitt]# gdb /usr/sbin/rp3-config
GNU gdb 19991004
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(gdb) r
Starting program: /usr/sbin/rp3-config

GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified
are supported and host-based authentication failed.

Program received signal SIGSEGV, Segmentation fault.
chunk_free (ar_ptr=0x74, p=0x404ec098) at malloc.c:2985
2985	malloc.c: No such file or directory.
Current language:  auto; currently c
(gdb) bt
#0  chunk_free (ar_ptr=0x74, p=0x404ec098) at malloc.c:2985
#1  0x40457d75 in __libc_free (mem=0x404ec0a0) at malloc.c:2959
#2  0x807a5b1 in svCloseFile (s=0x80cef28) at shvar.c:371
#3  0x807a851 in interface_shvarfiles_close (ifcfg=0x80cef28) at interface.c:86
#4  0x807afb0 in interface_free (i=0x80d3068) at interface.c:371
#5  0x8053b7b in load_accounts () at account.cc:432
#6  0x805ec5e in rp3_mainwin_new () at mainwin.cc:518
#7  0x80663f5 in main (argc=1, argv=0xbffffc04) at main.cc:149
(gdb) quit
The program is running.  Exit anyway? (y or n) y
[root@Learn leavitt]#

I know very little about gdb so I can only hope that this helps.
Comment 3 Michael K. Johnson 1999-12-02 15:52:59 EST
This shows memory corruption that has happened well before the
segfault.  I can't reproduce this, so I'm pretty sure that it has
something to do with what data files you have, which would explain
why I can't reproduce it.

If you are comfortable with building software from source code,
you can rebuild with -lefence and see if the backtrace changes.
Otherwise, post the contents of your /etc/wvdial.conf file and
your /etc/sysconfig/network-scripts/ifcfg-* files with all
sensitive information (e.g. usernames, passwords, phone numbers
x'ed out).  Alternatively, you can mail me those files privately
if you would rather not post them here:

tar czf /tmp/archive.tar.gz /etc/wvdial.conf /etc/sysconfig/network-scripts
uuencode /tmp/archive.tar.gz archive.tar.gz | \
  mail johnsonm@redhat.com -s 'archive for bug 7462'
Comment 4 nstn1291 1999-12-02 19:39:59 EST
[leavitt@Learn leavitt]$ ls /etc/wvdial.conf
ls: /etc/wvdial.conf: No such file or directory
[leavitt@Learn leavitt]$ ls /etc/sysconfig/network-scripts/
chat-istar  ifcfg-ppp0	 ifdown-ppp    ifup-ipx   ifup-routes
chat-ppp0   ifcfg-ppp1	 ifdown-sl     ifup-plip  ifup-sl
ifcfg-	    ifdown	 ifup	       ifup-post  network-functions
ifcfg-lo    ifdown-post  ifup-aliases  ifup-ppp
[leavitt@Learn leavitt]$ more /etc/sysconfig/network-scripts/ifcfg-ppp0
DEVICE="ppp0"
ONBOOT="no"
USERCTL="no"
MODEMPORT="/dev/modem"
LINESPEED="115200"
PERSIST="yes"
DEFABORT="yes"
DEBUG="yes"
INITSTRING="ATZ"
DEFROUTE="yes"
HARDFLOWCTL="yes"
ESCAPECHARS="no"
PPPOPTIONS=""
PAPNAME=""
REMIP=""
NETMASK=""
IPADDR=""
MRU=""
MTU=""
DISCONNECTTIMEOUT=""
RETRYTIMEOUT="5"
BOOTPROTO="none"
[leavitt@Learn leavitt]$ more /etc/sysconfig/network-scripts/ifcfg-ppp1
DEVICE=ppp1
NAME=istar
WVDIALSECT=istar
MODEMPORT=/dev/ttyS1
LINESPEED=115200
PAPNAME=nstn1291@fox.nstn.ca
USERCTL=true
ONBOOT=no
DNS1=204.191.136.2
DNS2=198.53.144.2
[leavitt@Learn leavitt]$

OK - it appears that I do not have a /etc/wvdial.conf file.
As you can see I have two "ifcfg" files - ppp0 and ppp1.  I have no idea why
they contain what they do.  I have never attempted to use or change them.
However, they do contain some information that could only have come from me.
This must have happened during failed attempts to use various tools to get the
modem working in this machine.  I did succeed in getting it working, but I do
not use ppp0 or ppp1 to operate it now.
Comment 5 nstn1291 1999-12-02 19:43:59 EST
[leavitt@Learn leavitt]$
[leavitt@Learn leavitt]$ more /etc/sysconfig/network-scripts/ifcfg-
DEVICE=
ONBOOT=yes
BOOTPROTO=none
[leavitt@Learn leavitt]$ more /etc/sysconfig/network-scripts/ifcfg-lo
DEVICE=lo
IPADDR=127.0.0.1
NETMASK=255.0.0.0
NETWORK=127.0.0.0
# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
NAME=loopback
BOOTPROTO=none
[leavitt@Learn leavitt]$

Two other ifcfg files that are in the directory.
Comment 6 Michael K. Johnson 1999-12-03 09:57:59 EST
Remove the /etc/sysconfig/network-scripts/ifcfg- file.  I don't know
why it is there, but removing it is safe and appropriate.

The current development sources for rp3 fix the bug in rp3, so our
upcoming errata release will also solve this problem.
Comment 7 nstn1291 1999-12-03 18:50:59 EST
OK - I have deleted the unnecessary "ifcfg-" file.  rp3-config still core dumps
every time I try to use it.
Comment 8 Michael K. Johnson 1999-12-06 15:44:59 EST
Remove /etc/sysconfig/network-scripts/ifcfg-ppp1
and then use rp3-config to recreate it.

I think that the problem is that you have
WVDIALSECT=istar
in /etc/sysconfig/network-scripts/ifcfg-ppp1 and that causes
rp3 to assume that there is an /etc/wvdial.conf that should
contain the [Dialer istar] section.

I'll try to fix that for the next release, but in the meantime,
I expect that removing that file and recreating it will fix the
problem.
Comment 9 nstn1291 1999-12-06 23:53:59 EST
I removed
/etc/sysconfig/network-scripts/ifcfg-ppp1
as root and tried to run rp3-config.
It still aborts immediately.

When I tried to run rp3-config as another user other than root, it asked me
for a password, then aborted.

In a terminal window I can run "rp3-config --help" and it works fine.
The program seems to get into trouble when it tries to present its first
GUI screen.
Comment 10 Michael K. Johnson 1999-12-08 19:58:59 EST
OK, I think I know what problem this was, and I think it is fixed in the
latest test release at
ftp://people.redhat.com/johnsonm/rp3/rp3-1.0.3-1.i386.rpm
Please let me know either way.  I'm hoping to make an official
errata update if I hear back from enough folks that this version
fixes their problems.  :-)
Comment 11 nstn1291 1999-12-08 21:58:59 EST
rp3-1.0.3-1.i386.rpm
I tried it and it works like a charm.  Congradulations!
Configuring my modem with this tool tool less than 2 minutes.
Configuring it manually using ppp, chat, and /etc/resolv.conf to me 3 weeks.

The rp3 tool is still a bit weak.  When originally setting up the modem it does
not ask about the DNS addresses that are needed for my ISP.  These are the
addresses I previously put in /etc/resolv.conf.  I would have found that very
confusing if I had not known about it in advance.

Looks like this one is nailed down.....
Comment 12 Michael K. Johnson 1999-12-09 17:01:59 EST
Most ISPs export DNS information via the msdns extension, and we
automatically pick that up by default.  We want the default setup
path to be as *simple* as possible, and then folks with less common
connection issues can go into advanced setup and tune things as
needed.  It's there, under the advanced tab.

Make sure you have the latest initscripts so that that information
is put into /etc/resolv.conf correctly in every circumstance.  (The
version of initscripts shipped with Red Hat Linux 6.1 will correctly
change nameserver entries, but will not add new ones.  Oops.)
Comment 13 nstn1291 1999-12-09 20:35:59 EST
Thanks for the information.  I did not know that you automatically pick up DNS
information.

I believe that modems will be ancient history soon.  Cable connections or ASDL
seem to be all the rage.  I am looking forward to that change.
Comment 14 Nalin Dahyabhai 2000-01-31 05:18:59 EST
The problem with using multiple tools is that rp3 can set a WVDIALSECT
variable in the configuration file, and based on that the initscripts
package uses wvdial to initiate the connection.  But when you then modify
the interface using linuxconf or netcfg, the chat script that gets generated
is ignored because WVDIALSECT is still set.  This is fixed in the latest
netcfg in Raw Hide, and I'll close this bug when I add the same fix to
linuxconf, hopefully this week.
Comment 15 ljoas 2000-02-13 00:38:59 EST
Hi.

I also had a problem with rp3-config coredumping, but I don't know if it's
related to this bug. Anyway, I found that my problem was due to me having
an old ppp cfg file from an earlier RH release that didn't have a
WVDIALSECT keyword. That meant that rp3-config crashed in load_accounts()
function in the account.cc file.

This small patch seems to fix my problem (indentation not updated):

--- account.cc.org      Sun Feb  6 12:54:53 2000
+++ account.cc  Sun Feb 13 13:39:23 2000
@@ -427,11 +427,8 @@
           char* tmp;

           tmp = svGetValue (iface->ifcfg, "WVDIALSECT");
-          if (tmp == NULL)
+          if (tmp != NULL)
             {
-              interface_free (iface);
-              continue;
-            }
           free (tmp);
           a = account_new(iface);

@@ -467,6 +464,7 @@
           accounts = g_slist_prepend(accounts, a);

           g_free (cfg);
+            }
         }
       else
         {

Regards.

Lars
Comment 16 Stephen John Smoogen 2003-01-24 18:26:36 EST
Bug 7462 has been closed because Red Hat Linux 6.1 and the rp3 package have been
deprecated in recent releases. The newer tools do not seem to have this problem
anymore.

Note You need to log in before you can comment on or make changes to this bug.