This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 746210 - The usermod command can not expand groups
The usermod command can not expand groups
Status: CLOSED DUPLICATE of bug 745675
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-14 07:10 EDT by Singer Michael
Modified: 2011-10-14 07:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-14 07:22:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Singer Michael 2011-10-14 07:10:06 EDT
Description of problem:
While expanding the group membership of a user, an error occurs. I want to record the user "michael" in the group "users" with the following command in the console:

# usermod -a -G users michael
# echo $?
0

When executing this command does not error or it is not displayed. The return code is zero. In the file /etc/group the user is listed as a member of the group "users".

# grep users /etc/group
users:x:100:michael

Now, when I command "id" is the newly added group "user" in the user "michael" is not displayed.

# id michael
uid=1000(michael) gid=1000(michael) Gruppen=1000(michael)

Thus, the user "michael" no rights "users" group.


Version-Release number of selected component (if applicable):
shadow-utils-4.1.4.3-7.fc16.x86_64

How reproducible:
Repeatedly reproduced on each execution of the command.

Steps to Reproduce:
see obove
  
Actual results:
It can not be added to other user groups.

Expected results:


Additional info:

# uname -a
Linux diego 3.1.0-0.rc9.git0.0.fc16.x86_64 #1 SMP Wed Oct 5 15:30:54 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Fedora installation media: Fedora-16-Beta-x86_64-netinst.iso

All installed software has been updated today (10/14/2011) and is up to date. Let me know if you still need additional information.

Regards
Michael Singer
Comment 1 Tomas Mraz 2011-10-14 07:22:22 EDT

*** This bug has been marked as a duplicate of bug 745675 ***

Note You need to log in before you can comment on or make changes to this bug.