Bug 746257 - “Man subscription-manager “Displays wrong example for activation key
“Man subscription-manager “Displays wrong example for activation key
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
IDM QE LIST
: Documentation
Depends On:
Blocks: rhsm-rhel62 748554
  Show dependency treegraph
 
Reported: 2011-10-14 10:52 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:25:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
edited manpage (28.86 KB, text/plain)
2011-10-17 11:57 EDT, Deon Ballard
no flags Details
edited manpage #2 (28.85 KB, text/plain)
2011-10-17 19:18 EDT, Deon Ballard
no flags Details

  None (edit)
Description spandey 2011-10-14 10:52:24 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Prerequisites:
Rhel6.2 client with following rpm 
subscription-manager-firstboot-0.96.15-1.el6.x86_64
.
subscription-manager-gnome-0.96.15-1.el6.x86_64.

subscription-manager-0.96.15-1.el6.x86_64
.

Steps to Repro : 

Execute following command on console to display subscription manager man page 

man subscription-manager 
check for activationkey info 

Expected Result : 
It should display no user and password is required for activation key registration  

Actual Result : 
subscription-manager register --username=admin --password=secret

              --org="IT Dept" –activationkey=1234abcd
Comment 3 John Sefler 2011-10-14 11:41:25 EDT
Deon,
Just to help clarify... the REGISTER OPTIONS/--activationkey=KEYS section of the subscription-manager man page is pasted below.   In this section we'd like to remove "--username=admin --password=secret" from the example.  You could also add a note to the effect that the no username and password are needed when registering with an activationkey because the authentication is implied in the key.  <- Maybe Bryan or Will can help with that wording.




       --activationkey=KEYS
              Gives  a  comma-separated  list  of  product  keys  to  use to redeem or apply specific subscriptions to the machine. This is used generally for preconfigured
              machines, which may already have products installed and subscriptions allocated for that consumer.  For example:
              subscription-manager register --username=admin --password=secret
              --org="IT Dept" --activationkey=1234abcd

       Giving the org name is not necessary in hosted environments or infrastructures which have only a single organization.
Comment 4 Deon Ballard 2011-10-17 11:57:50 EDT
Created attachment 528574 [details]
edited manpage

I changed the --activationkey example as indicated, and I also added a little note about the authentication and --org stuff, also as indicated.
Comment 6 John Sefler 2011-10-17 18:15:22 EDT
NEEDINFO from bkearney or wpoteat...

When the --activationkey option is used, it is not necessary to use the --username and --password options, because the user information and authentication is implicit in the activation key.

^^^
Is the "because...." clause of Deon's re-worded description from attachment 528574 [details] of the activationkey option accurately stated?  I don't think "the user information and" should be in this sentence.
Comment 7 Bryan Kearney 2011-10-17 19:10:29 EDT
The user information is not in the key but the authentication information is.
Comment 8 Deon Ballard 2011-10-17 19:18:59 EDT
Created attachment 528673 [details]
edited manpage #2

Removed the user reference. Users are gone and only authentication remains.
Comment 9 James Bowes 2011-10-18 09:37:20 EDT
fixed in rhel6.2 eafe19ba
and master 7615c9054817c6
Comment 11 John Sefler 2011-10-18 12:28:29 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.15-1.git.7.fbf42c7.el6.x86_64

[root@jsefler-onprem-62server ~]# man subscription-manager

...SNIP...

       --activationkey=KEYS
              Gives  a  comma-separated  list of product keys to use to redeem or apply specific subscriptions to the machine. This is used generally for preconfigured machines, which may already have products installed and subscriptions allocated for that consumer.

       When the --activationkey option is used, it is not necessary to use the --username and --password options, because the authentication information is implicit in the activation key.

       In hosted or single organization environments, it is not necessary to specify an organization with the --org option, but in multi-organization environments, this is required.

       For example:
              subscription-manager register --org="IT Dept" --activationkey=1234abcd

       Giving the org name is not necessary in hosted environments or infrastructures which have only a single organization.

...SNIP...


^^^ THIS MAN PAGE DESCRIPTION FOR REGISTER OPTION --activationkey IS GOOD
Moving to VERIFIED
Comment 12 errata-xmlrpc 2011-12-06 12:25:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.