Bug 7463 - gnome help browser aborts
gnome help browser aborts
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-30 20:15 EST by nstn1291
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-17 14:29:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nstn1291 1999-11-30 20:15:16 EST
NOTE:  gnome-utils seemed to be the closest fit to the gnome-help-browser.
This is a bug report for the gnome-help-browser.

I ran the gnome-help-browser twice as shown by the following trace from the
X-window:

[root@Learn /root]# gnome-help-browser
Aborted (core dumped)
[root@Learn /root]# gdb gnome-help-browser
GNU gdb 19991004
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
(gdb) r
Starting program: /usr/bin/gnome-help-browser
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x405444e4 in chunk_alloc (ar_ptr=0x405d9040, nb=16) at malloc.c:2699
2699	malloc.c: No such file or directory.
(gdb) bt
#0  0x405444e4 in chunk_alloc (ar_ptr=0x405d9040, nb=16) at malloc.c:2699
#1  0x4054440a in __libc_malloc (bytes=5) at malloc.c:2643
#2  0x403b3ca6 in g_malloc () from /usr/lib/libglib-1.2.so.0
#3  0x403bc183 in g_strdup () from /usr/lib/libglib-1.2.so.0
#4  0x8050ed0 in newInfoTable ()
#5  0x804f754 in newToc ()
#6  0x804e698 in main ()
#7  0x405041eb in __libc_start_main (main=0x804e4f0 <main>, argc=1,
    argv=0xbffffbd4, init=0x804cdd8 <_init>, fini=0x80573fc <_fini>,
    rtld_fini=0x4000a610 <_dl_fini>, stack_end=0xbffffbcc)
    at ../sysdeps/generic/libc-start.c:90
(gdb) quit
The program is running.  Exit anyway? (y or n) y
[root@Learn /root]#

Both time the program aborted.

If I delete all then ".gnome*" directories the program then runs
correctly.  The directories will reappear so I assume that they are copied
if they do not exist.  I do not know what happened to cause this error, but
it has come back several times after being eliminated.
Comment 1 nstn1291 1999-12-03 18:48:59 EST
More information - I now believe that the problem is associated with the
gnome-help-browser directory.  When I deleted that directory the help browser
then started working correctly.  I think it re-creates the directory if it is
not there.  The "default" recreation seems to be OK - somehow it becomes
problematic as things change.  I don't know what changes cause the problem to
come back, but I have seem this problem come back about 10 times now.
Comment 2 nstn1291 1999-12-18 01:08:59 EST
When I log in as "root" the gnome-help-browser always core dumps immediately
when gnome tries to run it as part of its start up process.

It also core dumps when I try to invoke it.

The problem seems to be associated with the .gnome-help-browser/history file.
If I delete this file then the help browser can be invoked.

The file causing the problem appears to contain:
toc: 945294268 1

Hope this helps....
Comment 3 Elliot Lee 2000-01-17 14:29:59 EST
Please get the gnome-core errata for RHL 6.1 - gnome-help-browser has had a few
fixes since gnome-core 1.0.40.
Comment 4 yves 2000-03-19 14:23:59 EST
I'm using gnome-core 1.0.54 (release 2), the lastest RPM available from the RH
6.1 errata and I'm getting exactly the same problem as described, and the gdb
backtrace of the core dump is identical to the one described in the initial
entry for this bug.

I removed ~/.gnome-help-browser/history and that's temporarely fixed the
problem, but it's clear the problem will re-appear and thus this bug should be
re-opened.

Note You need to log in before you can comment on or make changes to this bug.